Bug 16222 - LC_CTYPE from enviroment is ignored,
Summary: LC_CTYPE from enviroment is ignored,
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnupg   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
: 24342 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-15 09:45 UTC by noa
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 14:56:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a patch that fixes the problem (383 bytes, patch)
2000-08-15 09:49 UTC, noa
no flags Details | Diff

Description noa 2000-08-15 09:45:08 UTC
the LC_CTYPE locale setting is not imported from the enviroment. This leads
to ugly translations of characters in different charsets than US-ASCII.
For example in swedish (test with LANG=sv) all occurances of e is
translated to aa and so forth. I will include a patch solve the problem

Comment 1 noa 2000-08-15 09:49:38 UTC
Created attachment 2496 [details]
a patch that fixes the problem

Comment 2 Nalin Dahyabhai 2000-08-15 21:41:04 UTC
This will be fixed in gnupg-1.0.2-2.  Thanks!

Comment 3 noa 2000-08-16 14:56:46 UTC
sorry to come with bad news, but i had an email discussion with Werner Koch
(gnupg maintainer)
and he notified me that some function calls in the gnupg source depend on the
LC_CTYPE locale
being set to C (notably isalpha() and friends). I will work to get a better
patch and come back to
you then.

Comment 4 Nalin Dahyabhai 2000-08-16 15:14:55 UTC
Aaargh.  Reverting the patch.

Comment 5 Daniel Roesen 2000-10-21 01:44:29 UTC
Hm. Now the 1.0.4 RPMs contain the following patch:

   #ifdef ENABLE_NLS
-    #ifdef HAVE_LC_MESSAGES
-       setlocale( LC_TIME, "" );
-       setlocale( LC_MESSAGES, "" );
-    #else
-       setlocale( LC_ALL, "" );
-    #endif
     bindtextdomain( PACKAGE, G10_LOCALEDIR );
     textdomain( PACKAGE );
+    setlocale( LC_ALL, "" );
   #endif

Is that really correct/needed? Nalin, could you please shed some light what the
effect of that change is? Is it a RH-only abnormally? If not, why did Werner not
fix this since 1.0.2?

BTW: does Werner know about the strlen fix?

-                && !strcmp(fname+strlen(defhome+1)-strlen(defhome+1),
+                && !strcmp(fname+strlen(fname)-strlen(defhome+1),


Comment 6 Nalin Dahyabhai 2001-01-20 23:45:43 UTC
*** Bug 24342 has been marked as a duplicate of this bug. ***

Comment 7 Nalin Dahyabhai 2001-01-20 23:50:05 UTC
Just double-checked my sent-mail folder.  We sent the patch to wk@gnupg.org on
10/19, so yes, it should show up in a forthcoming release.


Note You need to log in before you can comment on or make changes to this bug.