Bug 24342 - Non-ASCII characters in translated messages aren't shown correctly
Summary: Non-ASCII characters in translated messages aren't shown correctly
Status: CLOSED DUPLICATE of bug 16222
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnupg   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-19 09:17 UTC by Göran Uddeborg
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-20 23:45:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Göran Uddeborg 2001-01-19 09:17:34 UTC
Recent versions of gnupg, like 1.0.4-9, includes translated messages. 
Recent versions of gettext, like that from glibc 2.2, translates fetched
messages to the used character set.  If no character set has been choosen
with setlocale(LC_CTYPE, ...), a plain US-ASCII is assumed.  Any characters
not in this set is replaced with question marks.  This happens to the
Swedish messages for gpg.

The 1.0.4-9 SRPM includes a patch for this, gnupg-1.0.2-locale.patch (patch
#0).  But for some reason this patch isn't applied.  Why not?

Comment 1 Nalin Dahyabhai 2001-01-20 23:45:46 UTC
GnuPG depends on collation data for the C locale, so the patch would cause
things to break.  We kept it in the package for future reference.

*** This bug has been marked as a duplicate of 16222 ***


Note You need to log in before you can comment on or make changes to this bug.