Bug 1623333 - [3.11] swap is not disabled when running 3.10 -> 3.11 upgrade
Summary: [3.11] swap is not disabled when running 3.10 -> 3.11 upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.11.z
Assignee: Russell Teague
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On: 1588611
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-29 06:14 UTC by Johnny Liu
Modified: 2019-01-10 09:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Deprecated Functionality
Doc Text:
The ability to leave swap enabled has been removed and the openshift_disable_swap variable is deprecated. This variable was never publicly documented and was only used internally. Documentation has stated that system swap should be disabled since 3.4 and we will no longer make sure it is disabled after 3.9.
Clone Of: 1588611
Environment:
Last Closed: 2019-01-10 09:03:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0024 None None None 2019-01-10 09:04:05 UTC

Comment 4 Russell Teague 2018-11-05 19:14:55 UTC
We will stop disabling swap on every upgrade because we've required swap to be disabled since 3.4.  This PR is for removing the optional variable which was never publicly documented.

release-3.11: https://github.com/openshift/openshift-ansible/pull/10604

Comment 5 Russell Teague 2018-11-07 13:15:16 UTC
Fixed in openshift-ansible-3.11.40-1

Comment 6 Johnny Liu 2018-11-09 11:06:25 UTC
According to comment 2, we decide to leave the disable task out of 3.11 upgrade, but in 3.10 fresh install.

I tried a 3.10 fresh install with openshift-ansible-3.10.71-1.git.0.3e9431a.el7.noarch, even I set "openshift_disable_swap=false" in inventory file, "Disable swap" task is still called, the PR is working well as expected.

I also tried a 3.11 fresh install with openshift-ansible-3.11.41-1.git.0.f711b2d.el7.noarch, set "openshift_disable_swap=false" in inventory file, "Disable swap" task is still called, the PR is working well.

Comment 8 errata-xmlrpc 2019-01-10 09:03:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0024


Note You need to log in before you can comment on or make changes to this bug.