Bug 162363 - HP PhotoSmart 2610 not automatically detected and set up
HP PhotoSmart 2610 not automatically detected and set up
Status: CLOSED DUPLICATE of bug 144536
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-03 07:31 EDT by Daniel Roesen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 08:41:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Roesen 2005-07-03 07:31:15 EDT
After installation and booting into X11 (firstboot), system detects the
HP PhotoSmart 2610 connected via USB, but doesn't automatically chose the right
driver even that it's there ("PHOTOSMART 2600"). The USB ID string of the
printer is "Photosmart 2600 series".

I'm not sure wether "firstboot" is the right component to chose. Please reassign
to correct component who's responsible if necessary.
Comment 1 Tim Waugh 2005-07-08 06:09:00 EDT
Please run 'system-config-printer' from a terminal window and copy the output
you get into a comment on this bug report.  Thanks.
Comment 2 Daniel Roesen 2005-07-08 07:14:17 EDT
Uhm, you really mean the curses-based window graphics?
Comment 3 Tim Waugh 2005-07-08 07:56:19 EDT
No -- I mean start a terminal window from your graphical login session, and run
'system-config-printer' inside that.  It will start the graphical application,
but will show useful information in debugging your problem in the terminal window.
Comment 4 Daniel Roesen 2005-07-14 19:25:49 EDT
I'm not sure what you need off that, but I guess you mean the automatically
generated queue name: "photosmart-2600-series--1".
Comment 5 Tim Waugh 2005-07-26 07:14:27 EDT
No, that's not what I need.  The terminal window should be giving you
instructions to file a bug report.  Are you not seeing that?
Comment 6 Marius Andreiana 2005-07-27 13:16:12 EDT
Daniel: Right click on desktop, clic Open Terminal in popup menu.
In that window type
system-config-printer
and press enter. After entering the root password (if it asks), copy-paste the
output from the terminal here.
Comment 7 Daniel Roesen 2005-07-27 15:42:50 EDT
(In reply to comment #5)
> No, that's not what I need.  The terminal window should be giving you
> instructions to file a bug report.  Are you not seeing that?

Nope. It just shows the X11 stuff. Nothing sent to stdout.
Comment 8 Tim Waugh 2005-07-28 04:22:38 EDT
In that case there is no IEEE 1284 ID returned by this printer, so we can't key
off it.
Comment 9 Daniel Roesen 2005-07-28 07:06:49 EDT
Hrm, and what about taking the USB device string?

# cat /sys/bus/usb/devices/3-2/product
Photosmart 2600 series
Comment 10 Tim Waugh 2005-07-28 07:28:04 EDT
No, that's no good.
Comment 11 Daniel Roesen 2005-07-28 07:34:51 EDT
Hm, what's wrong about it? As far as I know, a lot of other stuff uses that
to key off too. E.g. SANE, kudzu etc...
Comment 12 Tim Waugh 2005-07-28 07:43:50 EDT
Every other printer (really, without exception) has an IEEE 1284 ID string.  We
key off that.

According to the foomatic database, this printer *does* have an ID string
though, so I think you'll need to be more specific about what exactly does and
does not happen:

1. "system [...] does not automatically choose the right driver" -- what do you
mean by this?  Which application are you using?  What does happen?

2. With system-config-printer, what do you see when you add a new queue for this
printer?  Does it select the correct model in the list?
Comment 13 Daniel Roesen 2005-07-28 08:15:01 EDT
I specifically said "system" as I don't know which software does the job at
firstboot time. If I remember correctly it says that it detected the printer,
but also said that it couldn't find an appropriate driver, and popped up a
driver selection list. I didn't run a specific application, it was as I wrote
in my initial report firstboot time. First X11 login.

Unfortunately this is my production desktop machine, so I cannot just reinstall
that easily to reproduce. I'll have to dig up a spare harddisk and to a fresh
installation there.

Deleting the automatically created queue and adding it new, using /dev/usb/lp0
it doesn't select any printer model automatically. I have to chose manually.

Interestingly, when doing a first "Edit" on the auto-added queue, I had the
following on stdout/stderr:

*** glibc detected *** perl: malloc(): memory corruption: 0x08f27c70 ***
======= Backtrace: =========
/lib/libc.so.6[0x6d63ea]
/lib/libc.so.6[0x6d709b]
/lib/libc.so.6(__libc_realloc+0x101)[0x6d7d30]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(Perl_safesysrealloc+0x5a)[0xa83603]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(Perl_sv_grow+0x122)[0xaa2c67]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(Perl_sv_catpvn_flags+0x125)[0xaac16c]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(Perl_sv_vcatpvfn+0x12ca)[0xaa918c]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(Perl_sv_vsetpvfn+0x6e)[0xaaa2c0]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(Perl_vmess+0x6c)[0xa83021]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(S_vdie_croak_common+0x33)[0xa8319f]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(Perl_vdie+0x48)[0xa83328]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(Perl_die+0x31)[0xa833f4]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(Perl_pp_ioctl+0x2c2)[0xade1af]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(Perl_runops_debug+0x141)[0xa7e6e1]
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so(perl_run+0x445)[0xa30fe1]
perl(main+0x130)[0x80493f4]
/lib/libc.so.6(__libc_start_main+0xc6)[0x686de6]
perl[0x8049241]
======= Memory map: ========
0053d000-0053e000 r-xp 0053d000 00:00 0
00654000-0066e000 r-xp 00000000 03:01 4944208    /lib/ld-2.3.5.so
0066e000-0066f000 r-xp 00019000 03:01 4944208    /lib/ld-2.3.5.so
0066f000-00670000 rwxp 0001a000 03:01 4944208    /lib/ld-2.3.5.so
00672000-00796000 r-xp 00000000 03:01 4944209    /lib/libc-2.3.5.so
00796000-00798000 r-xp 00124000 03:01 4944209    /lib/libc-2.3.5.so
00798000-0079a000 rwxp 00126000 03:01 4944209    /lib/libc-2.3.5.so
0079a000-0079c000 rwxp 0079a000 00:00 0
0079e000-007c0000 r-xp 00000000 03:01 4944210    /lib/libm-2.3.5.so
007c0000-007c1000 r-xp 00021000 03:01 4944210    /lib/libm-2.3.5.so
007c1000-007c2000 rwxp 00022000 03:01 4944210    /lib/libm-2.3.5.so
007c4000-007c6000 r-xp 00000000 03:01 4944211    /lib/libdl-2.3.5.so
007c6000-007c7000 r-xp 00001000 03:01 4944211    /lib/libdl-2.3.5.so
007c7000-007c8000 rwxp 00002000 03:01 4944211    /lib/libdl-2.3.5.so
008b5000-008c3000 r-xp 00000000 03:01 4944212    /lib/libpthread-2.3.5.so
008c3000-008c4000 r-xp 0000d000 03:01 4944212    /lib/libpthread-2.3.5.so
008c4000-008c5000 rwxp 0000e000 03:01 4944212    /lib/libpthread-2.3.5.so
008c5000-008c7000 rwxp 008c5000 00:00 0
009c7000-009d0000 r-xp 00000000 03:01 4944213    /lib/libgcc_s-4.0.0-20050520.so.1
009d0000-009d1000 rwxp 00009000 03:01 4944213    /lib/libgcc_s-4.0.0-20050520.so.1
009d3000-009e2000 r-xp 00000000 03:01 4944214    /lib/libresolv-2.3.5.so
009e2000-009e3000 r-xp 0000e000 03:01 4944214    /lib/libresolv-2.3.5.so
009e3000-009e4000 rwxp 0000f000 03:01 4944214    /lib/libresolv-2.3.5.so
009e4000-009e6000 rwxp 009e4000 00:00 0
00a0a000-00b49000 r-xp 00000000 03:01 1414895   
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so
00b49000-00b54000 rwxp 0013e000 03:01 1414895   
/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so
00b54000-00b56000 rwxp 00b54000 00:00 0
00c02000-00c04000 r-xp 00000000 03:01 4943138    /lib/libutil-2.3.5.so
00c04000-00c05000 r-xp 00001000 03:01 4943138    /lib/libutil-2.3.5.so
00c05000-00c06000 rwxp 00002000 03:01 4943138    /lib/libutil-2.3.5.so
022ce000-022d3000 r-xp 00000000 03:01 4944227    /lib/libcrypt-2.3.5.so
022d3000-022d4000 r-xp 00004000 03:01 4944227    /lib/libcrypt-2.3.5.so
022d4000-022d5000 rwxp 00005000 03:01 4944227    /lib/libcrypt-2.3.5.so
022d5000-022fc000 rwxp 022d5000 00:00 0
07fdf000-07ff1000 r-xp 00000000 03:01 4944220    /lib/libnsl-2.3.5.so
07ff1000-07ff2000 r-xp 00011000 03:01 4944220    /lib/libnsl-2.3.5.so
07ff2000-07ff3000 rwxp 00012000 03:01 4944220    /lib/libnsl-2.3.5.so
07ff3000-07ff5000 rwxp 07ff3000 00:00 0
08048000-0804b000 r-xp 00000000 03:01 1352816    /usr/bin/perl
0804b000-0804d000 rw-p 00002000 03:01 1352816    /usr/bin/perl
08f11000-08f32000 rw-p 08f11000 00:00 0          [heap]
b7b00000-b7b21000 rw-p b7b00000 00:00 0
b7b21000-b7c00000 ---p b7b21000 00:00 0
b7ccc000-b7ced000 rw-p b7ccc000 00:00 0
b7ced000-b7cee000 r--p 02761000 03:01 1345152    /usr/lib/locale/locale-archive
b7cee000-b7d20000 r--p 00f38000 03:01 1345152    /usr/lib/locale/locale-archive
b7d20000-b7f20000 r--p 00000000 03:01 1345152    /usr/lib/locale/locale-archive
b7f20000-b7f23000 rw-p b7f20000 00:00 0
b7f3c000-b7f3d000 rw-p b7f3c000 00:00 0
bf927000-bf93d000 rw-p bf927000 00:00 0          [stack]
sh: line 1:  2131 Aborted                 perl -e
'ioctl(STDIN,0x84005001,$result);print $result' 2>/dev/null </dev/usb/lp0

The same pops up when I did a "rescan" in the device selection dialog of
"new queue".
Comment 14 Tim Waugh 2005-07-28 08:40:50 EDT
Okay, another instance of this perl bug.
Comment 15 Tim Waugh 2005-07-28 08:41:56 EDT

*** This bug has been marked as a duplicate of 144536 ***
Comment 16 Daniel Roesen 2005-07-28 08:49:18 EDT
So that means that the autodetection of the printer is actually prevented by
this perl bug?

I have no perl clue, but the crash info in 144536 does look unrelated to me...

Note You need to log in before you can comment on or make changes to this bug.