Bug 16241 - upgrade: script execution failed
upgrade: script execution failed
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 16419 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-15 10:54 EDT by Brock Organ
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-31 11:12:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-08-15 10:54:38 EDT
Here is an error message from an anaconda upgrade (/tmp/upgrade.log)
showing an error upgrading apache:

Upgrading apache.                                                          
/bin/linuxconf: error while loading shared libraries: libncurses.so.4:
cannot open shared object file: No    such file or directory               
warning: /etc/httpd/conf/httpd.conf saved as
/etc/httpd/conf/httpd.conf.rpmsave
execution of linuxconf-1.17r2-6 script failed, exit status 127             
Upgrading apache-devel.                                                    
Upgrading
apache-manual.
Comment 1 Red Hat Bugzilla 2000-08-15 18:13:56 EDT
That's unfortunate.  The trigger which dies, however, isn't an important one,
and all of the packages involved still function correctly after the upgrade.
Comment 2 Red Hat Bugzilla 2000-08-17 11:03:58 EDT
The trigger is also gone from the package in the build tree, so we're looking at
a bug in the old version of the package that turned out to be harmless.
Comment 3 Red Hat Bugzilla 2000-08-17 11:05:00 EDT
*** Bug 16419 has been marked as a duplicate of this bug. ***
Comment 4 Red Hat Bugzilla 2000-08-27 11:26:44 EDT
Upgrading 6.2 to RC2 gives the same problem. 
For some reason, the fix is to install db2 (or db1, don't remember; anyway, it's the one
containing the missing lib for apache).
Comment 5 Red Hat Bugzilla 2000-08-31 11:12:20 EDT
the issues resolution would require an errata to linuxconf for 6.2 (purely for
the purpose of removing this message, as core functionality is not affected)...

This is a lower priority issue ... and as such we will defer to the next release
...
Comment 6 Red Hat Bugzilla 2000-09-06 14:53:35 EDT
The fact that apache is not upgraded does not look low priority to me.
Am I missing something (perhaps wrt internal cuts)  ?
Comment 7 Red Hat Bugzilla 2000-09-21 21:39:34 EDT
Why not make apache require linuxconf? If linuxconf gets upgraded
first, will this problem go away?

Note You need to log in before you can comment on or make changes to this bug.