This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 162443 - Update to Eclipse 3.1 in FC4
Update to Eclipse 3.1 in FC4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks: 158951 159880 159881 159939 161691 170244
  Show dependency treegraph
 
Reported: 2005-07-04 16:03 EDT by Andrew Overholt
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.1.1-1jpp_1fc.FC4.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-09 15:21:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2005-07-04 16:03:45 EDT
SSIA
Comment 1 Andrew Overholt 2005-09-01 17:28:33 EDT
Just so people know, this is still waiting on the CVS issue fix.
Comment 2 Tadej Janež 2005-09-02 03:56:47 EDT
Thanks for the info.

I hope the CVS issues get resolved ASAP, so we can finally have Eclipse 3.1 on FC4.
Comment 3 mario neto 2005-10-01 12:23:59 EDT
Hi, next week this bug is going to be 3 months old.  Any news regarding this
issue ?  For a distro that heavly focused on development (specially in java) I
think this may be too much.
Comment 4 Andrew Overholt 2005-10-02 08:15:38 EDT
As I said on 1 September (and as is indicated by the dependency tree), this is
waiting on bug 161483.
Comment 5 Andrew Overholt 2005-10-28 16:22:12 EDT
Please test eclipse-3.1.1-1jpp_1fc.FC4.4 when it appears in updates-testing (see
fedora-announce-list (and/or fedora-test-list)).
Comment 6 Charles C. Van Tilburg 2005-11-09 08:23:00 EST
Cannot update:

# rpm -Fvh eclipse*
error: Failed dependencies:
        eclipse-rcp = 1:3.1.1-1jpp_1fc.FC4.4 is needed by
eclipse-platform-3.1.1-1jpp_1fc.FC4.4.i386
        libswt3-gtk2 = 1:3.1.1-1jpp_1fc.FC4.4 is needed by
eclipse-platform-3.1.1-1jpp_1fc.FC4.4.i386
        lucene is needed by eclipse-platform-3.1.1-1jpp_1fc.FC4.4.i386
        lucene-demo is needed by eclipse-platform-3.1.1-1jpp_1fc.FC4.4.i386
Comment 7 Andrew Overholt 2005-11-09 15:21:52 EST
yum update eclipse-pde (or eclipse-jdt or eclipse-platform or whatever)

That'll bring in the deps you need.
Comment 8 Charles C. Van Tilburg 2005-11-09 15:31:46 EST
Negative.  The mirror at kernel.org does not contain the files and
I refuse to use yum.
Comment 9 Charles C. Van Tilburg 2005-11-09 15:45:38 EST
Correction: the files do exist in the mirror.

rpm -Fvh is just too stupid to see the files sitting there, so one
must install them manually, then run the rpm -Fvh.
Comment 10 Charles C. Van Tilburg 2005-11-09 15:46:42 EST
Also, the elipse*rcp* stuff is a fun little tar baby.
Comment 11 Andrew Overholt 2005-11-09 18:38:51 EST
(In reply to comment #8)
> I refuse to use yum.

May I ask why?

Comment 12 Charles C. Van Tilburg 2005-11-09 18:50:46 EST
Sure.  I don't need yum.  And I don't want to be tracked.  

I mirror the updates repository and run an 'rpm -Fvh *.rpm'.  I maintain 
that this should work without pain.

Sitting in a mirror'ed rpm update repository, FRESHEN should be able to 
figure things out and do the right thing.  In this case (FCOL!) its a 
FRESHEN DEPENDANCY, sitting right there, and its even on the friggin'
command line: 'rpm -Fvh *.rpm'!

If 'rpm -Fvh' worked correctly, things would be easier.  But its OK, I 
can do it manually.  Red Hat is getting more like Microsoft every day.

According to the idiot in charge of maintaining rpm, in response to my bug 
report about this issue, my suggestions for improvement, and expectations
for correct and reasonable behaviour of the tool, are not welcome.

I will be considering a move to another distro, and set of tools that 
works right.
Comment 13 Charles C. Van Tilburg 2005-11-09 18:57:28 EST
Further, since I have managed up to 150 machines by myself, I think client 
access to such a read-only update repository mirror, from which they can 
all do an 'rpm -Fvh *.rpm' has a certain network bandwidth good-citizen 
type of cache effect.  

But if the 'Package Manager' tool is defective, obviously, there will be 
annoying and unnecessary problems.

Note You need to log in before you can comment on or make changes to this bug.