Bug 158951 - menu label incorrect (%Refactoring.menu.label)
menu label incorrect (%Refactoring.menu.label)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Pound
ftp://65.28.47.173/pub/screenshots/ec...
:
: 160185 160273 160279 160993 161235 162675 167475 171269 (view as bug list)
Depends On: 162443
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-26 22:08 EDT by Justin Conover
Modified: 2007-11-30 17:11 EST (History)
11 users (show)

See Also:
Fixed In Version: cdt M6.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-06 10:49:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Justin Conover 2005-05-26 22:08:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
view screen shot

ftp://65.28.47.173/pub/screenshots/eclipse-error-menu.png

The menu has incorrect label "%Refactoring.menu.label"

File Edit Refactoring.menu.label Navigate Search .........

This is on a x86_64, and 2 i386 box's up to the latest rawhide level.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M7.7

How reproducible:
Always

Steps to Reproduce:
1. Open Eclipse
2. View menu
3.
  

Actual Results:  Menu incorrect

Expected Results:  Correct Menu

Additional info:

 rpm -qa | grep eclipse
eclipse-ecj-3.1.0_fc-0.M7.7
eclipse-jdt-3.1.0_fc-0.M7.7
eclipse-platform-3.1.0_fc-0.M7.7
eclipse-bugzilla-0.1.0_fc-16
eclipse-changelog-2.0.1_fc-21
eclipse-pydev-0.9.3_fc-7
eclipse-cdt-3.0.0_fc-0.M6.7
Comment 1 Jeff Pound 2005-05-27 13:55:04 EDT
This appears to be fixed in M7.8 (may not have propogated to rawhide mirrors
yet). Can you confirm when M7.8 is available?
Comment 2 Andrew Overholt 2005-06-02 16:37:30 EDT
It's caused by the CDT and I don't think it's fixed yet.  Re-opening for now
(unless you tested with all these packages installed, Jeff?).
Comment 3 Jeff Pound 2005-06-02 16:44:29 EDT
ah, I didn't realize that. I didn't have the CDT installed.
Comment 4 Justin Conover 2005-06-02 18:42:55 EDT
Problem is still there and it does look like CDT is the off version #

$ rpm -qa | grep eclipse
eclipse-platform-3.1.0_fc-0.M7.8
eclipse-changelog-debuginfo-2.0.1_fc-21
eclipse-cdt-3.0.0_fc-0.M6.7
eclipse-pydev-debuginfo-0.9.3_fc-7
eclipse-pde-3.1.0_fc-0.M7.8
eclipse-cdt-debuginfo-3.0.0_fc-0.M6.7
eclipse-jdt-3.1.0_fc-0.M7.8
eclipse-pde-devel-3.1.0_fc-0.M7.8
eclipse-pydev-0.9.3_fc-7
eclipse-debuginfo-3.1.0_fc-0.M7.8
eclipse-platform-devel-3.1.0_fc-0.M7.8
eclipse-bugzilla-debuginfo-0.1.0_fc-16
eclipse-bugzilla-0.1.0_fc-16
eclipse-changelog-2.0.1_fc-21
eclipse-jdt-devel-3.1.0_fc-0.M7.8
eclipse-ecj-3.1.0_fc-0.M7.8
Comment 5 Jeff Pound 2005-06-06 10:49:46 EDT
the org.eclipse.cdt.refactoring/plugin.properties file wasn't being included in
the build.

Fixed in eclipse-cdt-3.0.0_fc-0.M6.8
Comment 6 Andrew Overholt 2005-06-13 08:09:56 EDT
This will go out as an update to FC4.
Comment 7 Andrew Overholt 2005-06-13 08:10:16 EDT
*** Bug 160185 has been marked as a duplicate of this bug. ***
Comment 8 Andrew Overholt 2005-06-14 10:27:59 EDT
*** Bug 160273 has been marked as a duplicate of this bug. ***
Comment 9 Andrew Overholt 2005-06-14 10:29:18 EDT
*** Bug 160279 has been marked as a duplicate of this bug. ***
Comment 10 Jeff Pound 2005-06-14 10:56:12 EDT
*** Added some search bait to the Summary. ***
Comment 11 Andrew Overholt 2005-06-20 09:48:51 EDT
*** Bug 160993 has been marked as a duplicate of this bug. ***
Comment 12 Aaron Luchko 2005-06-21 12:23:14 EDT
*** Bug 161235 has been marked as a duplicate of this bug. ***
Comment 13 Paul De Audney 2005-06-22 08:36:36 EDT
eclipse-platform-3.1.0_fc-0.M6.22
eclipse-pde-devel-3.1.0_fc-0.M6.22
eclipse-ecj-3.1.0_fc-0.M6.22
eclipse-changelog-2.0.1_fc-21
eclipse-cdt-3.0.0_fc-0.M6.7
eclipse-platform-devel-3.1.0_fc-0.M6.22
eclipse-bugzilla-0.1.0_fc-16
eclipse-jdt-devel-3.1.0_fc-0.M6.22
eclipse-pydev-0.9.3_fc-7
eclipse-jdt-3.1.0_fc-0.M6.22
eclipse-pde-3.1.0_fc-0.M6.22

[paul@Iketsu config-samples]$ uname -ri
2.6.11-1.1369_FC4 x86_64

As reported, this problem exists in FC4 X86_64 release.
Comment 14 Andrew Overholt 2005-06-22 10:20:55 EDT
This problem exists on all architectures.  We will not be pushing out an update
to FC4 until Eclipse 3.1 is released (next week some time).  If you want the fix
now, grab the CDT from rawhide (fedora-development).
Comment 15 Paul De Audney 2005-06-23 09:11:42 EDT
OK thanks, sorry for the cross / double post.
Comment 16 Andrew Overholt 2005-06-23 09:17:05 EDT
No prob :)
Comment 17 Jeff Pound 2005-07-07 11:53:33 EDT
*** Bug 162675 has been marked as a duplicate of this bug. ***
Comment 18 Andrew Overholt 2005-09-06 09:49:05 EDT
*** Bug 167475 has been marked as a duplicate of this bug. ***
Comment 19 Felix Schwarz 2005-10-05 09:49:19 EDT
Eclipse 3.1 is stable since the end of June and the Eclipse foundation released
3.1.1 on September 30. CDT 3.0 was officially released on August 31. But still I
can see no updated rpm in the official Fedora repositories (besides testing of
course).

Are there special issues that are blocking the release? I could help with QA if
there are concrete problems.

fs
Comment 20 Andrew Overholt 2005-10-05 09:53:50 EDT
Sorry, I should have made this bug depend up on bug 162443.  That bug depends
upon bug 161483 which I am working on.  As soon as we have a fix for the CVS
issues, I'll push an update of both the Eclipse SDK and the CDT.

Thanks for the offer of help.  When I get a fix for the CVS issues, I'll put the
updates in updates-testing.  If you could help with testing then, it'd be great.
Comment 21 Andrew Overholt 2005-10-20 11:30:44 EDT
*** Bug 171269 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.