Bug 1624534 - Transition from g-i-s to desktop fails in current Rawhide and F29
Summary: Transition from g-i-s to desktop fails in current Rawhide and F29
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F29BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-09-01 02:18 UTC by Adam Williamson
Modified: 2018-09-05 18:02 UTC (History)
9 users (show)

Fixed In Version: gdm-3.30.0-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-05 18:02:09 UTC


Attachments (Terms of Use)
journal contents from the affected boot (167.93 KB, text/plain)
2018-09-01 02:20 UTC, Adam Williamson
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab /GNOME/gdm/issues/415 None None None 2018-09-04 16:48:26 UTC

Description Adam Williamson 2018-09-01 02:18:51 UTC
If you install from a current Rawhide Workstation live, e.g.:

https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20180831.n.0/compose/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-Rawhide-20180831.n.0.iso

and boot the installed system, it boots to gnome-initial-setup - so far, so good. g-i-s works fine, apparently, it gets all the way through user creation. You click "Start using Fedora" and...it drops back to a console showing boot messages. That's it. It never reaches a desktop, or GDM.

tty2 seems to be occupied by something when this happens (if you switch to tty2 it just shows a black screen, it never shows a console login prompt). tty3 shows a console login prompt and you can log in successfully as the user you just created. Looking at the system logs shows an at-spi-dbus-bus.service failing to start likely due to more complete fail on the part of the dbus-broker Change, but nothing else obvious.

If you reboot the system, it boots to GDM, and you can log in. It then runs the user g-i-s, which it should not for the user that was created by the 'no existing user' g-i-s process. Once you make it through the user g-i-s, you finally get to a desktop.

If this also affects F29 (as I'm guessing it will) it will be an F29 Beta blocker, but will wait till we get a working F29 compose to verify that.

Assigning to GDM as I'm guessing this is along the same lines as https://bugzilla.redhat.com/show_bug.cgi?id=1618794 ...

Comment 1 Adam Williamson 2018-09-01 02:20:59 UTC
Created attachment 1480177 [details]
journal contents from the affected boot

Comment 2 Adam Williamson 2018-09-01 20:48:36 UTC
openQA testing of latest 29 compose shows the same bug:

https://openqa.fedoraproject.org/tests/272835

Proposing as a Beta blocker per Basic criterion "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility."

Comment 3 Geoffrey Marr 2018-09-04 20:00:44 UTC
Discussed during the 2018-09-04 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criteria:

"A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility."

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-04/f29-blocker-review.2018-09-04-16.01.txt

Comment 4 Fedora Update System 2018-09-04 20:02:42 UTC
gdm-3.30.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-81a7d8ed40

Comment 5 Lukas Ruzicka 2018-09-05 08:48:12 UTC
I have tried to verify this and I can confirm, that the new version of gdm (#4) solves the problem.

After the reboot, it boots to gnome-initial-setup, creates the user and then logs in the newly created user.

The only flaw, I have experienced, is that gnome-initial-setup actually ran twice. For the first time, I clicked Next on Geolocation service and that usual stuff, then it let me create the user, and then I went through the same process again for the next user.

Comment 6 Fedora Update System 2018-09-05 18:02:09 UTC
gdm-3.30.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.