Bug 1624682 - Traceback after `dnf group install 'Minimal Install'`
Summary: Traceback after `dnf group install 'Minimal Install'`
Keywords:
Status: CLOSED DUPLICATE of bug 1596827
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Mach
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F29FinalBlocker 1628844
TreeView+ depends on / blocked
 
Reported: 2018-09-03 05:08 UTC by Miroslav Suchý
Modified: 2018-09-14 19:13 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1628844 (view as bug list)
Environment:
Last Closed: 2018-09-14 19:13:51 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Miroslav Suchý 2018-09-03 05:08:53 UTC
Description of problem:
I upgraded from F28 to F29 using fedora-upgrade(8). This basically runs:
  dnf --releasever=f29 --setopt=deltarpm=false --enablerepo=updates-testing distro-sync
This command runs without any issue. But then I the script runs:
  dnf group install 'Minimal Install'
which ends with traceback.

Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 1047, in run
    return self.command.run()
  File "/usr/lib/python3.7/site-packages/dnf/cli/commands/group.py", line 423, in run
    self.base.conf.strict)
  File "/usr/lib/python3.7/site-packages/dnf/base.py", line 1647, in env_group_install
    res = q.get(pattern)
  File "/usr/lib/python3.7/site-packages/dnf/comps.py", line 177, in get
    installed = self.history.env.search_by_pattern(pat)
  File "/usr/lib/python3.7/site-packages/dnf/db/group.py", line 147, in search_by_pattern
    return self.history.swdb.getCompsEnvironmentItemsByPattern(pattern)
  File "/usr/lib/python3.7/site-packages/dnf/db/history.py", line 291, in swdb
    self._swdb = libdnf.transaction.Swdb(self.dbpath)
  File "/usr/lib64/python3.7/site-packages/libdnf/transaction.py", line 713, in __init__
    this = _transaction.new_Swdb(*args)
RuntimeError: C++ std::exception: Step: UNIQUE constraint failed: comps_environment_group.environment_id, comps_environment_group.groupid in

        INSERT INTO
            comps_environment_group (
                environment_id,
                groupid,
                installed,
                group_type
            )
        VALUES
            (40558, 'core', 1, 4)



Version-Release number of selected component (if applicable):
dnf-3.3.0-2.fc29.noarch

How reproducible:
happened to me twice out of two tries.

Steps to Reproduce:
1. upgrade to F29
2. dnf group install 'Minimal Install'

Comment 1 Fedora Blocker Bugs Application 2018-09-03 05:15:21 UTC
Proposed as a Blocker for 29-final by Fedora user msuchy using the blocker tracking app because:

 This is a bug in
  dnf group install 'Minimal Install'
which users are advised to run as part of the upgrade process.

Comment 2 Miroslav Suchý 2018-09-06 10:24:41 UTC
Note: with dnf-3.2.0-2.fc29.noarch after this upgrade, I am not able to even run "dnf upgrade". I am getting this traceback for any operation I have tried.

Comment 3 Miroslav Suchý 2018-09-14 07:27:36 UTC
Still valid even with dnf-3.5.1-1.fc29.noarch

Comment 4 Adam Williamson 2018-09-14 19:13:51 UTC

*** This bug has been marked as a duplicate of bug 1596827 ***


Note You need to log in before you can comment on or make changes to this bug.