Bug 1624773 - [admin] CatalogSources link is wrong on Overview page of both Subscription and Initial Plans
Summary: [admin] CatalogSources link is wrong on Overview page of both Subscription an...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Alec Merdler
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1619198 1624754 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-03 09:10 UTC by XiaochuanWang
Modified: 2019-06-04 10:40 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:41 UTC

Description XiaochuanWang 2018-09-03 09:10:50 UTC
Description of problem:
Link of "ocs" on both Subscription and Initial Plans Overview page are wrong.

Version-Release number of selected component (if applicable):
OpenShift Web Console:    v3.11.0-0.25.0
"io.openshift.source-repo-commit": "c4f3f9fafa60fbcb188b6fed9b48a177a8f3e723"

How reproducible:
always

Steps to Reproduce:
1. install openshift enabled OLM
2. create subscription for etcd in Catalog Sources
# oc get catalogsource -n operator-lifecycle-manager
NAME      NAME                  TYPE       PUBLISHER   AGE
ocs       Open Cloud Services   internal   Red Hat     5d
3. On the created subscription-> Overview page, check link of Catalog "ocs"
4. Go to Initial Plans -> (select one) Overview page, check link of Catalog Sources "ocs"

Actual results:
Both 3&4. Link to /k8s/ns/xiaocwan-t/operators.coreos.com:v1alpha1:CatalogSource/ocs

Expected results:
Both 3&4. Link should contain correct namespace: k8s/ns/operator-lifecycle-manager/catalogsources/ocs

Additional info:

Comment 1 Alec Merdler 2018-09-04 17:14:16 UTC
*** Bug 1624754 has been marked as a duplicate of this bug. ***

Comment 2 Alec Merdler 2018-09-04 17:15:12 UTC
*** Bug 1619198 has been marked as a duplicate of this bug. ***

Comment 3 Samuel Padgett 2018-09-04 19:49:53 UTC
https://github.com/openshift/console/pull/490

Comment 5 XiaochuanWang 2018-09-06 02:58:15 UTC
Sorry for typo. Checked and assigned back on v3.11.0-0.28.0
registry.reg-aws.openshift.com:443/openshift3/ose-console                   v3.11               8479e847d3a8        3 hours ago


Install Plans overview page is still using "/k8s/ns/openshift/operators.coreos.com:v1alpha1:CatalogSource/ocs" for Catalog Sources.
Name space is not "openshift", it should be "operator-lifecycle-manager".

Subscriptions overview page is correct.

Comment 6 Yadan Pei 2018-09-06 08:13:05 UTC
Fix PR https://github.com/openshift/console/pull/499

Comment 7 Yadan Pei 2018-09-13 01:17:44 UTC
New fix PR https://github.com/openshift/console/pull/521

Comment 8 Yadan Pei 2018-09-17 08:22:47 UTC
Hi Jakub,

PR 521 is merged to 'master' branch so it's not merged in ose-console image with source-repo-commit d822672dec05b2aec2f421295b3f87e9d42493c4, should I backport to release-3.11? Or set target release to 4.0?

Comment 9 Samuel Padgett 2018-09-17 13:27:38 UTC
I've updated the bug to the correct target release (4.0).

Comment 10 Yadan Pei 2018-09-18 00:38:03 UTC
Change to MODIFIED since we set target release to 4.0

Comment 12 XiaochuanWang 2018-12-03 09:41:53 UTC
Both links on Subscription page and Initial Plans page are correct.
This fix is verified on Openshift v4.0.0-0.80.0

Comment 15 errata-xmlrpc 2019-06-04 10:40:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.