Bug 16260 - german dead keys broken again
Summary: german dead keys broken again
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-15 15:58 UTC by Michael Redinger
Modified: 2014-03-17 02:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-18 06:38:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Redinger 2000-08-15 15:58:58 UTC
Ok, I was asked to move this away from bug #13525 as it's a seperate issue.
Just moving the contents to this bug:

Both with XFree 3 and 4 dead keys do not work as expected (ie. ~, ' etc.
shouldn't be dead keys) (german keyboard).

Comment 1 Bill Nottingham 2000-08-15 16:31:24 UTC
Do you have a:

	Option "XkbVariant" "None"

in your X config file?
If so, does changing it to:

	Option "XkbVariant" ""

fix it?

If so, this just got fixed.

Comment 2 Michael Redinger 2000-08-15 16:38:42 UTC
No, XkbVariant is not set. Although the following would resolve the problem:

Option "XkbVariant" "nodeadkeys"


Comment 3 Bill Nottingham 2000-08-15 16:40:52 UTC
But wouldn't that break anything that *should* be a dead key?

Comment 4 Michael Redinger 2000-08-15 16:48:43 UTC
Hm, I don't know about the other keyboards/languages, but for german this is
perfectly okay, there aren't any left ... see also de-latin1-nodeadkeys, works
the same way
Hm, this shouldn't however break "de-latin1" and "de" ... should be checked ... 
I don't even know what "de" is exactly for, seems like de-latin1-nodeadkeys
without the "umlaute" and some other minor mapping differences. However, it
doesn't seem to have any dead keys (therefore it should probably be called
de-nodeadkeys). de-latin1 does have them, the other two not.

Comment 5 Bill Nottingham 2000-08-18 21:14:42 UTC
Sorry, I'm having problems comprehending the problem. Is
the problem that when you choose de-latin1-nodeadkeys,
there are still some keys treated as deadkeys?

Comment 6 Michael Redinger 2000-08-18 21:22:40 UTC
Yes, exactly. Console (/etc/sysconfig/keyboard) is set to de-latin1-nodeadkeys.
Xconfigurator however generates a keymapping with dead keys (X installation did
generate de-latin1  - not de-latin1-nodeadkeys; was a seperate bug; will have a
look at this in RC2 again, but this seems to be solved).

Comment 7 Bill Nottingham 2000-08-18 21:25:13 UTC
Ooh, I don't know how Xconfigurator does the mappings - Trond?

Comment 8 Trond Eivind Glomsrxd 2000-08-19 16:10:54 UTC
Easy: Xconfigurator doesn't support dead keys at all, as there is no such info
in /etc/sysconfig/keyboard. This will be added in the rewrite. Everything works
nicely in X install (tested) where you get to specify that.

Comment 9 Michael Redinger 2000-08-19 16:22:51 UTC
Leaving this DEFERRED. However, I have to correct you. For german keyboards
/etc/sysconfig/keyboard _does_ contain information about dead keys - de-latin1
and de-latin1-nodeadkeys.
(Will test the german dead keys issue in RC2 again)

Comment 10 Trond Eivind Glomsrxd 2000-08-19 16:26:13 UTC
That's just the name of the keyboard map. I would have to special case it to
make that work... (and for others, like Norwegian, there is no such info on that
choice at all). Basically, we'll have to add a field like that to the file.

Comment 11 Michael Redinger 2000-08-22 09:26:38 UTC
Still leaving as deferred, although I absolutely disagree. Things still don't
work in RC2. Tried anaconda install, Xconfigurator and Xconfigurator
--preferxf4. German dead keys configuration is still broken (so this should
probably not be in Xconfigurator as anaconda is affected as well.)
As noted above, Option XkbVariant "nodeadkeys" does the trick.


Comment 12 Michael Redinger 2001-07-06 11:29:44 UTC
As this is still true for Fairfax, I'll reopen it ... plans to change this for the coming release?



Comment 13 Mike A. Harris 2002-04-18 06:38:46 UTC
I've caught wind that debian might have a fix.  Hunting ....

Comment 14 Mike A. Harris 2002-11-03 07:35:26 UTC
Should be fixed in Red Hat Linux 8.0.  Please reopen if it doesn't work
for you.


Note You need to log in before you can comment on or make changes to this bug.