Bug 13525 - Backspace doesn't work
Backspace doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
:
: 13357 20360 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-06 09:05 EDT by Tim Waugh
Modified: 2008-05-01 11:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-02 16:03:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-07-06 09:05:10 EDT
Backspace and delete both erase the character under the cursor under X. 
Ctrl-H rubs out the character before the cursor.
Comment 1 Red Hat Bugzilla 2000-07-27 16:24:41 EDT
Reproduced in Pinstripe in: 

konsole in KDE
xterm (started from konsole from KDE by hand)
gnome-terminal in Gnome

I should use CTRL+H to delete char as backspace usually do.
Comment 2 Red Hat Bugzilla 2000-07-27 16:34:19 EDT
*** Bug 13357 has been marked as a duplicate of this bug. ***
Comment 3 Red Hat Bugzilla 2000-07-31 14:30:33 EDT
I filed a bug for something like this in beta 2, but removed it in beta 4 as
it was fixed then (the bug is still there, now in kdebase as backspace was
still an issue with kdm -  see Bug 13344). Tried this again (german keyboard,
keyboard
mapping de-latin1-nodeadkeys selected during installation):

After install, backspace is broken. AltGr doesn't work (nowhere). On the
console, I do see the following X errors (well, this is XFree 3  which is used
for ATI as default):

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            No Symbols named "" in the include file "de"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server
Couldn't load XKB keymap, falling back to pre-XKB keymap
mach64ProgramClkMach64CT: Warning: Q < 10.66666667
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            No Symbols named "" in the include file "de"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server
Couldn't load XKB keymap, falling back to pre-XKB keymap
mach64ProgramClkMach64CT: Warning: Q < 10.66666667

After doing the configuration using Xconfigurator, backspace is working,
but AltGr (well, useful for doing things like typeing "[" on a german
keyboard ... :) ) still isn't.

Then I used Xconfigurator, but used --preferxf4 (this is still missing from
tge man pages - #14900).
Surprise - kdm finally shows a nice background. It didn't with XFree 3
(#14901).
Backspace works. And AltGr does too - but the chars generated are treated as
dead keys.

Think this is a must-fix.

Comment 4 Red Hat Bugzilla 2000-07-31 14:32:25 EDT
Correction - not all keys are treated as dead keys, only the tilde.
Comment 5 Red Hat Bugzilla 2000-08-01 07:20:29 EDT
Wrong again - this is also true for all other "classical" dead keys (which have
nothing to do with AltGr) - "^", "'", "`"
Comment 6 Red Hat Bugzilla 2000-08-03 17:06:13 EDT
I "discovered" this annoying bug too...
Comment 7 Red Hat Bugzilla 2000-08-03 17:13:35 EDT
The "Swap DEL/Backspace" setting in gnome-terminal seems to have no effect. =(

Maybe it's time to send a reminder to the list so that it actually gets some
developer's attention and gets fixed in time for release...
Comment 8 Red Hat Bugzilla 2000-08-04 07:00:13 EDT
I might add that in my case I'm testing it with a Swedish keyboard and Swedish
mapping, and it's not just gnome-terminal where backspace doesn't work but all
other X programs too.
Comment 9 Red Hat Bugzilla 2000-08-04 07:45:24 EDT
Redoing the X configuration, after the install, with Xconfigurator 4.3.38-1 from
http://people.redhat.com/teg/xc/ solved my problem with Backspace. Both
Backspace and Delete now works as expected in X with my Swedish keyboard.
Comment 10 Red Hat Bugzilla 2000-08-04 07:49:45 EDT
Same here with the new Xconfigurator. However, both with XFree 3 and 4 dead keys
do not work as expected (ie. ~, ' etc. shouldn't be dead keys) (german
keyboard).
Comment 11 Red Hat Bugzilla 2000-08-04 07:58:46 EDT
Please file the german-specific keyboard problems under a new bug and keep this
to the backspace problem - the backspace problem affects a lot of different
layouts, not just the german one.
(FYI, the Swedish keyboard layout is working excellent - probably because I
filed the bugs with accented characters and dead keys in time for RH 6.2, see
bug 9380 ;-)
Comment 12 Red Hat Bugzilla 2000-08-04 08:52:29 EDT
I'm not sure already but it seems that the problem is in XFree 4.x. When the proper national keymap is invoked from /etc/X11/XF86Config (Anaconda 
set national keymap during the installation process) the Backspace key does'n work. This problem go away when national XKB is invoked from the 
command line (ie by setxkbmap command). I really don't know if this is the core of the problem. I'll dig aroud this issue this evenig and I fill more 
comment later.
Comment 13 Red Hat Bugzilla 2000-08-09 08:53:18 EDT
Backspace is now working for me in the current (internal) build.
Comment 14 Red Hat Bugzilla 2000-08-10 10:24:57 EDT
...but it's broken again in Pinstripe2.  uk keymap.
Comment 15 Red Hat Bugzilla 2000-08-10 11:06:49 EDT
During the installation, when I was selecting the keymap, backspace worked fine
in the type-in box.

/usr/sbin/fix_bs_and_del doesn't seem to have any effect.

xmodmap -e 'keycode 22 = BackSpace' cures the problem here.
Comment 16 Red Hat Bugzilla 2000-08-11 16:13:29 EDT
This is really Must-Fix.
Comment 17 Red Hat Bugzilla 2000-08-12 18:16:07 EDT
Here, on RC1 with US English with deadkeys layout and deadkeys enabled, neither
backspace nor delete do anything at all.
Comment 18 Red Hat Bugzilla 2000-08-15 10:52:55 EDT
trond, bero:  please work together to figure out what the hell is going on here
and get it done before RC2.
Comment 19 Red Hat Bugzilla 2000-08-15 12:21:23 EDT
The defaults for a new user seem to work perfect for me in emacs, xterm and
gnome-terminal - fresh install (RC1 + all updated packages, but e.g. X hasn't
been updated yet and no changes for this has been made for anaconda.)

This was a GUI install, and after reconfiguring with Xconfigurator it still
works. 

All tests done with a German keyboard (even AltGR works :)
Comment 20 Red Hat Bugzilla 2000-08-15 12:23:57 EDT
Note, this was backspace/delete/altgr. For other bugs, please open separate
ones.
Comment 21 Red Hat Bugzilla 2000-10-08 07:58:29 EDT
I think I've finally tracked down the problem that caused me to log this bug in
the first place.

In /etc/X11/XF86Config, if I change:

     XkbLayout   "gb"
     XkbVariant  ""
     XkbOptions  ""

to:

     XkbLayout   "gb"
#     XkbVariant  ""
     XkbOptions  ""

then everything works fine.  So for some reason, specifying an XkbVariant of ""
breaks in 7, where it worked fine in 6.2.
Comment 22 Red Hat Bugzilla 2000-10-18 05:51:49 EDT
I'm changing the component to anaconda.  Xconfigurator sets up XF86Config right,
it's just the installer that puts the XkbVariant line in there in the first
place.
Comment 23 Red Hat Bugzilla 2000-12-14 16:14:49 EST
I will test on the newest internal builds when I get a chance.  I've fixed a few
bugs related to German keyboards...bug #13600 and another one I can't remember
at the moment.
Comment 24 Red Hat Bugzilla 2001-01-02 16:03:09 EST
This has been fixed.  Brock, please verify this works.
Comment 25 Red Hat Bugzilla 2001-01-08 12:08:37 EST
verified that Tim's XF86Config is now what anaconda produces (ie the XKbVariant
line IS commented out) ... this was tested using the qa0108.0 test tree ...
Comment 26 Red Hat Bugzilla 2001-01-09 11:45:05 EST
*** Bug 20360 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.