Bug 1626839 - No default editor in Fedora 29 LXQt LiveCD
Summary: No default editor in Fedora 29 LXQt LiveCD
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spin-kickstarts
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Václav Pavlín
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1648906 (view as bug list)
Depends On:
Blocks: F29BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-09-09 15:35 UTC by Zamir SUN
Modified: 2018-11-13 19:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-11 09:11:26 UTC


Attachments (Terms of Use)

Description Zamir SUN 2018-09-09 15:35:42 UTC
Description of problem:
No default editor in Fedora 29 LXQt LiveCD

Version-Release number of selected component (if applicable):
0.29.1-2

How reproducible:
Always

Steps to Reproduce:
1. Boot any Fedor 29 LXQt nightly LiveCD
2.
3.

Actual results:
No default editor

Expected results:
It would be nice to have a default editor.

Additional info:
The fix is https://pagure.io/fedora-kickstarts/pull-request/424

Comment 1 Lukas Ruzicka 2018-09-10 14:24:29 UTC
Yeah, would support this. 
In my opinion, it would be nice, if every spin would have some minimal set of required applications, such as a terminal, an editor, a browser, a file manager, etc.

Comment 2 Adam Williamson 2018-09-10 23:15:39 UTC
Discussed at 2018-09-10 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-10/f29-blocker-review.2018-09-10-16.01.html . Accepted as a freeze exception issue as an obvious UX deficiency in a desktop we ship live media for (thus cannot be fixed entirely with an update). The fix is clearly limited to the affected desktop so cannot hurt anything else.

Comment 3 Kevin Fenzi 2018-09-12 15:33:05 UTC
kickstarts PR merged. 

Note that this is not in the first beta rc that is just finishing composing now. 

It should be in any later ones provided we need those.

Comment 4 Raphael Groner 2018-09-12 18:41:34 UTC
Thanks. As the maintainer of enki, this makes me proud and happy to see the package included as default in a spin.

Please test if all needed dependencies are also there, we hit a bug recently related to not properly handled optional dependencies.
https://github.com/andreikop/enki/issues/425
https://github.com/andreikop/enki/issues/446
https://github.com/andreikop/enki/issues/450

Comment 5 Raphael Groner 2018-11-11 09:11:26 UTC
Closing. Please feel free to reopen if there's still an issue.

Comment 6 Raphael Groner 2018-11-13 19:45:32 UTC
*** Bug 1648906 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.