Bug 162993 - Anaconda Installer crashes while installing on an Apple iBook
Anaconda Installer crashes while installing on an Apple iBook
Status: CLOSED DUPLICATE of bug 161877
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-11 20:49 EDT by Ross Powell
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-12 11:19:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ross Powell 2005-07-11 20:49:42 EDT
Description of problem:
While trying to install Fedora Core 4 on my 12-inch Apple iBook, I get the 
following error just as it is about to begin the installation;

File “/usr/lib/anaconda/gui.py”, line 873, in nextClicked 
self.dispatch.gotoNext()
File “/usr/lib/anaconda/dispatch.py”, line 174, in gotoNext self.moveStep()
File “/usr/lib/anaconda/dispatch.py”, line 242, in moveStep rc = apply(func, 
self.bindArgs(args))
File “/usr/lib/anaconda/partitioning.py”, line 54, in 
particionObjectsInitialize partitions.setFromDisk ptype = 
partedUtils.get_partition_file_system_type(part)
File “/usr/lib/anaconda/partedUtils.py”, line 140, in 
get_partition_file_system_type elif (part.get_flag(parted.PARTITION_BOOT) == 1 
and
AttributeError: ‘NoneType’ object has no attribute ‘name’


Version-Release number of selected component (if applicable):


How reproducible:
Every time


Steps to Reproduce:
1) Boot the iBook from Disk 1 of the Fedora Core 4 for PPC.
2) Select all defaults for language, time zone, etc.
3) Choose to Remove All Paritions from the machine (since this is a clean 
install) and let Anaconda set up the partitions automatically
4) Before it starts to begin copying 
  
Actual results:
Anaconda terminates abnormally with the above error messages.

Expected results:
Begin to install the OS

Additional info:
Apple iBook laptop, bought circa Summer 2003:  12-inch screen; 900 MHz G3 CPU; 
256 MB RAM; 40 GB hard disk; ATI Radeon 7500; Airport card (802.11b).
Comment 1 Jeremy Katz 2005-07-12 11:19:42 EDT

*** This bug has been marked as a duplicate of 161877 ***
Comment 2 Zeid Zumot 2005-09-19 18:31:29 EDT
I had the same problem installing FC4 no a G3. The machine had 3 harddrives in 
it, hda, sda, and sdb. Mac OS 9 was installed on it before and it was working 
fine, but when I tried installing FC4 it keept giving me that error message. 
It also gave me the same message when I disconnected the SCSI drives, but when 
reconnected them and disconnected hda it installed fine. I guess it didn't 
like the mix of drives I had. I hope this help some of you in figuring out the 
cause of your problem.

Note You need to log in before you can comment on or make changes to this bug.