Bug 161877 - "Exception occurred" during installation, install bombs out
"Exception occurred" during installation, install bombs out
Status: CLOSED DUPLICATE of bug 170003
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
: 162993 163113 163480 165186 EverlovePR (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-27 20:39 EDT by Simon Chapman
Modified: 2007-11-30 17:11 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-26 17:20:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda_Crash_Dump_Bug_161877 (842.12 KB, text/plain)
2005-11-23 16:01 EST, Tim
no flags Details

  None (edit)
Description Simon Chapman 2005-06-27 20:39:24 EDT
Description of problem:

"Exception occurred" during installation, install bombs out

Version-Release number of selected component (if applicable):


How reproducible:

Happens every time

Steps to Reproduce:
1. Insert FC4 CD
2. Start installation
3. Get as far as choosing disk partitioning method
4. Error occurs

Actual results:

Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 242 moveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/partitions.py", line 108, in setFromDisk
  ptype = partedUtils.get_partition_file_system_type(part)
 File "/usr/lib/anaconda/partedUtils.py", line 140, in
get_partition_file_system_type
  elif (part.get_flag(parted.PARTITION_BOOT) == 1 and

AttributeError: 'NoneType' object has no attribute name

Expected results:

Progress and formatting of hard drive

Additional info:
Comment 1 Luis 2005-06-28 07:01:26 EDT
I have a very similar traceback when I try to install FC4 on a G5 imac. It
happens either with automatic partition and with diskdruid. The cd has correct
checksum and I am rtying an ftp installation.

Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/partitioninig.py", line 54, in partitionObjectsInitialize
    partitions.setFromDisk(diskset)
 File "/usr/lib/anaconda/partitions.py", line 108, in setFromDisk
    ptype = partedUtils.get_partition_file_system_type(part)
 File "/usr/lib/anaconda/partedUtils.py", line 140, in
get_partition_file_system_type
    elif(part.get_flag(parted.PARTITION_BOOT)) == 1 and
AttributeError: 'NoneType' object has no attribute 'name'
Comment 2 Tom Gutnick 2005-07-04 10:23:08 EDT
I got something similar, installing on a Gateway Pentium II system.  Same 
traceback, although prior to that I had gotten this warning:

error: Error: Error informing the kernel about modifications to partition /dev/
hda2 - Device or resource busy.  This means Linux won't know about any changes 
you made to /dev/hda2 until you reboot - so you shouldn't mount it or use it in 
any way before rebooting.

The system had been previously configured with a Windows 98 partition and a 
Linux (FC3) partition;  this time, I was attempting to do a clean install, 
telling Linux to use the entire disk.  A subsequent attempt at installation 
(albeit installing as "workstation" package selection instead of "custom") 
worked properly.
Comment 3 Paul Nasrat 2005-07-08 14:01:58 EDT
On the G5 imac, please can you switch to tty2 at the welcome to anaconda screen
and paste the output of the following to this bug report.  Can you also not any
error messages on tty3-5 when you get the exception: 

parted /dev/hda print
Comment 4 Jeremy Katz 2005-07-12 11:19:53 EDT
*** Bug 162993 has been marked as a duplicate of this bug. ***
Comment 5 Ross Powell 2005-07-13 22:50:16 EDT
Trying again, have additional details.  Did a complete "zero" of the iBook hard drive, after which Disk 
Utility it set up a Mac OS (HFS+) partition.  Now immediately after the keyboard language is selected, an 
error box appears saying "The partition's data region doesn't occupy the entire partition", and then 
"Attempt to read sectors 16-18 outside of partition on /dev/hda".  The error repeats just after it prompts 
for automatic vs. manual partitioning.  Not trying to overload you on information, just wanted to make 
sure you knew everything I knew.
Comment 6 Paul Nasrat 2005-07-14 08:32:24 EDT
Could you attach your partition table as shown by pdisk in Mac OS X.
Comment 7 Ross Powell 2005-07-14 11:42:38 EDT
Don't know what "pdisk" is.  Please advise.
Comment 8 Luis 2005-07-14 14:45:50 EDT
I attach the partition table given by pdisk as requested in #6.
I must say that this is the partition table I built with diskduid, the posts
requesting this information appeared later. Sorry. Diskdruid worked ok for me
but of course I had to reinstall MacOsX. At least this is a partition map which
works either for fedora and MacosX. The HD is a Sata of 149.05 GB 

output of pdisk /dev/disk0 -dump

#:                type name                 length   base        ( size )
1: Apple_partition_map Apple                    63 @ 1           
2:     Apple_Bootstrap untitled               2048 @ 64          (    1M)
3:     Apple_Unix_SVR2 untitled          143360000 @ 2112        ( 68.4G)
4:     Apple_Unix_SVR2 swap                8192000 @ 14336112    (  3.9G)
5:           Apple_HFX untitled          161027696 @ 151554112   ( 76.8G)

Comment 9 Jeremy Katz 2005-07-18 15:24:01 EDT
*** Bug 163480 has been marked as a duplicate of this bug. ***
Comment 10 Max 2005-07-20 20:40:46 EDT
Mr. Powell:
http://cantaforda.com/cfcl/eryk/linux/pdisk/pdisk.html
Comment 11 Jeremy Katz 2005-07-26 00:00:56 EDT
*** Bug 163113 has been marked as a duplicate of this bug. ***
Comment 12 Jeremy Katz 2005-08-08 18:01:55 EDT
*** Bug 165186 has been marked as a duplicate of this bug. ***
Comment 13 Andy Gray 2005-08-21 14:09:20 EDT
I recently found out (if it's important)-my motherboard is Soyo SY-6BA + III
the rest of the system specs are(as posted on my duplicate bug)



800 Mhz Celleron-133Mhz FSB

320 MB RAM

Korean Data Systems Visual Sensations-7e

NVIDIA TNT2 with 32 MB Video RAM on AGP slot

Trio64V2/DX with 4 MB Video RAM on PCI slot

Sound Blaster Live 5.1 sound card

3com EtherLink 10/100 (3C905C)

PCMCIA Adapter PCI card

PCMCIA CompactFlash adapter

hda-8GB internal

   hda1-2MB-Fat-Win2K boot

   hda2-100MB-ext3-/boot

   hda3-7.2GB-ext3-/

   hba4-704MB-swap

hdb-DVD+/-R/+/-RW internal

   cdrom-/mnt/cdrom

hdc-6GB internal

   hdc1-6GB-ext3-/mnt/ext3

hdd-6GB internal

   hdd1-6GB-ext3-/mnt/ext3b

hde-128MB CompactFalash card on PCMCIA adapter

   hde1-128MB-ext3-/mnt/CameraCard

sda-32MB imation USB pen drive

   sda1-32MB-vfat-/mnt/FlashDrive

HP DeskJet 632C on USB
Comment 14 Jason 2005-09-02 17:07:10 EDT
I get the same exception occurred as Comment 1 with an intel P4 D850GB 
motherboard (latest bios) doing an ftp and/or http install from a iis 6 
server.  This worked using fc3.
Comment 16 Nathan Cuperus 2005-10-30 21:02:01 EST
Another "Exception Occured" error... 

I get all the way through installation, after all the packages are installed and
one final progress bar comes up saying something about making final changes (I
haven't gotten a chance to read it all, it crashes almost as soon as the
progress bar starts).

Error message:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
    self.initf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/iutil.py", line 53, in execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /usr/sbin/kudzu can not be run
Comment 17 Jeremy Katz 2005-11-07 21:31:23 EST
*** Bug 171677 has been marked as a duplicate of this bug. ***
Comment 18 Tim 2005-11-23 15:56:01 EST
I get the same error on an IBM 6579-M6U PC with a P4 2.4 GHz and 512 MB of 
RAM.  The system did have 2000 Server installed the first time I got the 
error: "Error informing the kernel about modifications to partition /dev/hda2 -
 Device or resource busy.  This means Linux won't know about any changes you 
made to /dev/hda2 until you reboot - so you shouldn't mount it or use it in 
any way before rebooting."

I clicked Ignore and then got the "Exception Occured"

Wiped all the partions and started new this time letting the installer do an 
automatic partion instead and this time just got the "Exception Occured"

I have a dump and will attach to this bug.
Comment 19 Tim 2005-11-23 16:01:01 EST
Created attachment 121414 [details]
Anaconda_Crash_Dump_Bug_161877

This is the Anaconda Crash Dump of my system state at the time of the
"Exception Occured."
Comment 20 Tim 2005-11-23 16:18:09 EST
4th time is the charm.  Tried one more time and still got the same error.  
Tried a 4th time and got the formating filesystem progress bar instead of the 
Exception.  Looking through the other posts to this bug Tom Gutnick got it to 
work after three tries on a system that formerly had Windows.

Is it possible there is something about formatting/repartitioning a disk from 
Windows to ext3 that takes anaconda a few tries before it can overcome it?  I 
have installed over Windows with Fedora Core 2 in the past with no problems.

BTW, I was installing over Windows 2000 Server Standard Edition SP4 with a 4 
GB C: and approx 22 GB D: both NTFS.
Comment 21 Jeremy Katz 2005-11-26 17:20:35 EST

*** This bug has been marked as a duplicate of 170003 ***

Note You need to log in before you can comment on or make changes to this bug.