Bug 16300 - new xml style tags don't work properly with formmail
new xml style tags don't work properly with formmail
Status: CLOSED CURRENTRELEASE
Product: Red Hat Web Site
Classification: Red Hat
Component: Other (Show other bugs)
current
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lancaster
Paul Lindner
http://sassy.soma.redhat.com:8500/app...
:
: 16298 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-15 18:17 EDT by Maraya Cornell
Modified: 2007-04-18 12:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-15 20:44:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maraya Cornell 2000-08-15 18:17:17 EDT
I'm testing this form with the new xml style for dynamic tags. First, I get 
a lot of Internal Server Error messages. Those go away when I reload the 
page. The real problem is that the form will not accept any email addresses.  
For example, if I put maraya@redhat.com into the email field, the error 
message I get back says, "The e-mail address 'maraya.com' does not appear to 
be valid."  Is the @ some sort of special character that's getting erased?
Comment 1 Tom Lancaster 2000-08-15 19:00:05 EDT
The email address it's referring to is the one you put in the formmail
parameters, not the one you entered in the form. I don't know why it's getting
parsed, though. That's unrelated to the FillInForm stuff.
Also, if you don't specify METHOD=POST in the <FORM> tag, this might cause data
to hang around longer than it should.

Comment 2 Maraya Cornell 2000-08-15 19:09:35 EDT
Right, it isn't related to the fillin stuff at all.  In fact, I took out the 
fillin tags to reduce the number of variables. guess i should have mentioned 
that.

I added METHOD="POST". I'm still getting the same error. 
"The e-mail address 'maraya.com' does not appear to be valid." no matter what 
email address I put in there.
Comment 3 Maraya Cornell 2000-08-15 20:44:15 EDT
I get an Internal Server Error when I put that there.
Comment 4 Paul Lindner 2000-09-06 14:33:44 EDT
The latest fixes to the ASP.pm module should fix this.

Comment 5 Paul Lindner 2000-09-06 14:44:11 EDT
*** Bug 16298 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.