Bug 163263 - Partition errors installing FC4 on G4 iMac
Partition errors installing FC4 on G4 iMac
Status: CLOSED DUPLICATE of bug 159047
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-14 11:47 EDT by Heathe Kyle Yeakley
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 01:30:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Heathe Kyle Yeakley 2005-07-14 11:47:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I am trying to install Fedora Core 4 Release to dual boot on a G4 800 Mhz iMac running 384 

Mb or RAM and OS X Panther 10.3 for the primary OS.

While I have tried several different configurations, here is basically the error I encounter 

every time.

I boot off of the OS X install CD #1 and use Disk Utility to create 2 partitions: a 35 gig 

for OS X and a 20 gig for Fedora. Then I load OS X on the 35 gig and boot to the Fedora 

Install Disk. 

From there I choose the Linux boot option from yaboot.

I used the verify disk utility on all of my media. All passed.

After Anaconda runs, the Fedora splash screen pops up and the installation begins.

From the first page I choose next.

I select mouse options and click next.

On the keyboard select page, I choose the default English keyboard layout and get the 

following error when I click next.

            			Error
The partition's data region doesn't occupy the entire partition.
					Ignore	Cancel

I choose ignore. The error pops up 4 or 5 times, then recieve another error message.

				Error
Attempt to read sectors 16-18 outside of partition on /dev/hda
					Ignore	Cancel

I choose ignore. Eventually I can get passed that screen to select all of my other install 

parameters. BUT, I usually get one or the other or both after choosing the correct 

parameters on each screen. Again, if I choose ignore several times, I can eventually proceed 

with the installation.

Eventually, I arrive at the last screen before the actual formatting and installation 

begins. When I choose next for the last time, I get both of the aforementioned errors. Then 

I get one final error (forgive me for not writing it down, it was a very long string) and 

I'm given the error to debug or ... I forgot the other option. Either way, whichever option 

is chosen my entie screen goes completely pink and nothing happens. I have to manually power 

the system off.

I have tried several different partitioning schemes including just making one solid 

partition and loading ONLY Fedora, but I get the exact same errors every time.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot to FC4 installation on 800 Mhz G4 iMac
2. Try to install the OS under ANY partitioning scheme.
3.
  

Actual Results:  Screen errors out and goes completely pink.

Expected Results:  It should have began formatting the filesystem and installing packages.

Additional info:
Comment 1 Chris Lumens 2005-07-15 10:39:54 EDT
This is a duplicate of bug 159047.  Please see that bug for a more detailed
discussion of what's going on.  For a fix, download
http://people.redhat.com/clumens/mac-parted-update/updates.img, write it to a
floppy, and boot with "linux updates".  This should fix you up.
Comment 3 Chris Lumens 2005-07-15 11:20:30 EDT
You can also take the updates.img and use dd to write it to a USB key, then use
that with "linux updates" as well.  You will need to dd it to the entire device,
so make sure you backup whatever may be on the USB drive first.  You can do
something like this:

dd if=updates.img of=/dev/sda

Replace /dev/sda with the name of your USB key drive, though.
Comment 4 Rahul Sundaram 2005-09-05 01:30:46 EDT

*** This bug has been marked as a duplicate of 159047 ***

Note You need to log in before you can comment on or make changes to this bug.