Bug 159047 - anaconda has parted error where partition's data region doesn't occupy the entire partition
anaconda has parted error where partition's data region doesn't occupy the en...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
Brock Organ
:
: 163263 165883 185637 (view as bug list)
Depends On:
Blocks: FC4Update
  Show dependency treegraph
 
Reported: 2005-05-27 22:32 EDT by Colin Charles
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.6.22-3.FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-16 11:11:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Charles 2005-05-27 22:32:22 EDT
Description of problem: This is anaconda calling parted, so please feel free to
reassign to parted (clumens). From rawhide 20050526, burn the boot.iso, pop it
into the iBook 2.2 G3 800MHz that currently is:

15GB - Mac OS X 10.4 (tiger)
15GB - unpartitioned space (as performed by the apple installer)

Parted gives me an error the moment the X11 anaconda interface starts up (i.e.
after I give it NFS details).

parted exception: Error: The partition's data region doesn't occupy the entire
partition

I'm given the option to Ignore/Cancel. Clicking ignore twice, gives me:

parted exception: Error: Attemp to read sectors 16-18 outside of partition on
/dev/hda

And I can't partition, etc... Installer seems borked.

Version-Release number of selected component (if applicable):
anaconda-10.2.1.0-1.ppc.rpm
parted-1.6.22-2.ppc.rpm

How reproducible:
100%

I'm thinking the 20050527 tree is pointless to try, because anaconda didn't get
rebuilt.

I also tried booting with: "linux maxcpus=1 noisapnp", and it made no difference
(the kernel already had CONFIG_ISAPNP disabled in
kernel-2.6.11-1.1353_FC4.ppc.rpm anyways)

Priority high, because we seem to be wanting to make a release or something soon...
Comment 1 Colin Charles 2005-05-27 22:32:55 EDT
oops, powerpc.
Comment 2 Colin Charles 2005-05-27 22:42:08 EDT
This is actually similar to bug #158029 as well. And I tried what clumens
suggested (parted /dev/hda print) and I get the same error message with the
Ignore/Cancel option on the CLI at tty2
Comment 3 Paul Nasrat 2005-05-29 11:31:53 EDT
Does your free space volume have a name?  can you choose ignore and paste in
what parted says from print.  Did you use OS X diskutil to create the partitions?

You can grab pdisk from http://people.redhat.com/pnasrat/pdisk and check.

Chris and I looked at this and it's an issue with parted expecting free space to
be labled Extra (IIRC).

Comment 4 Colin Charles 2005-05-30 02:08:16 EDT
Free space volume has no name. I did choose ignore, and broke out to a shell,
and I got the ignore/error messages from the usual "parted /dev/hda print". Yes,
I used OS X diskutil to create the partition (this time I choose to not format
the 2nd partition as HFS+ but leave it as free space). 

Will have to try pdisk next, seeing that I don't have Linux installed (yet
another clean format issue. *groan*)
Comment 5 Colin Charles 2005-05-31 12:40:01 EDT
Okay, in console, after typing Ignore twice, I got parted to give me a print out

Disk geometry for /dev/hda: 0.000-28615.781 megabytes
Disk label type: mac
Minor	Start	End	Filesystem	Name		Flags
1	0.000	0.031			Apple
2	0.031	0.058			Macintosh
3 	0.059	0.085			Macintosh
4	0.086	0.113			Macintosh
5	0.113	0.140			Macintosh
6	0.141	0.390			Macintosh
7	0.391	0.640			Macintosh
8	0.641	0.890			Patch Partition
9	0.891	128.890	hfs
10	128.891	14308.781	hfs+	Apple_HFS_Untitled_2
11	14308.781 28615.773
12	28615.773 28615.781
Comment 6 Colin Charles 2005-05-31 12:48:51 EDT
and pdisk -l /dev/hda


Partition map (with 512 byte blocks) on '/dev/hda'
 #:                type name                   length   base     ( size )
 1: Apple_partition_map Apple                      63 @ 1       
 2:      Apple_Driver43*Macintosh                  56 @ 64      
 3:      Apple_Driver43*Macintosh                  56 @ 120     
 4:    Apple_Driver_ATA*Macintosh                  56 @ 176     
 5:    Apple_Driver_ATA*Macintosh                  56 @ 232     
 6:      Apple_FWDriver Macintosh                 512 @ 288     
 7:  Apple_Driver_IOKit Macintosh                 512 @ 800     
 8:       Apple_Patches Patch Partition           512 @ 1312    
 9:          Apple_Free                        262144 @ 1824     (128.0M)
10:           Apple_HFS "Hermione"           29040416 @ 263968   ( 13.8G)
11:          Apple_Free                      29300720 @ 29304384 ( 14.0G)
12:          Apple_Free                            16 @ 58605104

Device block size=512, Number of Blocks=58605120 (27.9G)
DeviceType=0x0, DeviceId=0x0
Drivers-
1:  23 @ 64, type=0x1
2:  36 @ 120, type=0xffff
3:  21 @ 176, type=0x701
4:  34 @ 232, type=0xf8ff

Comment 7 Chris Lumens 2005-06-01 11:23:13 EDT
It looks like you are doing an NFS install.  If so, are you able to add files to
the tree you're installing from?  If you can do that, I've got a test libparted
you can try out before we send the fix back upstream.  The procedure is:

(1) Make the directory RHupdates in the top level of the distribution tree (at
the same level as the README and everything, in other words).
(2) Download the contents of http://people.redhat.com/clumens/159047-update/ and
add them to the RHupdates directory.
(3) Also make the symlinks libparted-1.6.so.12 and libparted.so pointing to that
file as well.
(4) Boot up the machine you're installing, use the NFS method, and see if it works.
Comment 8 Colin Charles 2005-06-02 06:16:24 EDT
Hmm, dunno if Paul told you over the cubicles, but this did work, fwiw. I now
have a iBook that runs Fedora again, with a working parted. Thanks Chris.
Comment 9 Chris Lumens 2005-06-02 10:24:09 EDT
Glad to hear it.  I sent the patch upstream and if it's accepted, I'll be
releasing a parted update for FC4.
Comment 10 Frank Heldt 2005-06-15 09:16:13 EDT
I wanted to install final FC4-ppc (from CD) on my old PowerPC G4 today and hit 
the same problem. What can you do, if the only option is CD installation? At 
the moment FC4 final is not installable.
Comment 11 Chris Lumens 2005-06-15 10:27:43 EDT
Make sure your Apple_Free partitions have a name of "Extra".  This should allow
you to work around the problem and successfully install.
Comment 12 Paul Nasrat 2005-06-15 11:44:27 EDT
From fedora-ppc list but here so people can find it too

you can boot installer to first screen - switch to tty2

cd /tmp
wget http://people.redhat.com/pnasrat/pdisk
chmod 755 pdisk
./pdisk <disk>
n (Change name)
(freespace partition no)
Extra
w
q
Comment 13 Chris Lumens 2005-06-16 11:11:24 EDT
Pushed in update FEDORA-2005-420.
Comment 14 Jeff Francis 2005-06-23 15:46:18 EDT
Can you even wget at this point? I.e., is there network connectivity?

(In reply to comment #12)
> From fedora-ppc list but here so people can find it too
> you can boot installer to first screen - switch to tty2
> cd /tmp
> wget http://people.redhat.com/pnasrat/pdisk
> chmod 755 pdisk
> ./pdisk <disk>
> n (Change name)
> (freespace partition no)
> Extra
> w
> q

Comment 15 Jeff Francis 2005-06-23 17:22:09 EDT
Here was my workaround for installing Fedora 4 on a Mac Mini with dual boot 
Mac OS X

- Boot from Mac OS X Install DVD and go into the Disk Utility to create the 
partitions
- Created two equially sized partitions: 1 - Mac, 2 - Free space
- Proceeded to install OS X on the Mac partition
- Once all the OS X stuff was done, rebooted to Fedora 4 PPC DVD
- When the anaconda installer GUI comes up do a Ctrl+Opt+F2 to get to a shell
- Ran parted and did a "print" command (when you do this you'll get the 
formentioned errors). Ignore them and parted continues.
- Find the Free Space partitions (there are actually two partitions listed per 
partitions created with the Mac Disk Utility - a big one and a little one per 
partition - on my Mac Mini the two free partitions were #4 and #5)
- In parted do a "name" it will prompt for partition number enter 4 and then 
enter the name "Extra" and the name prompt
- Repeat for the  partition #5 (again see what print shows you and use those 
numbers vs. 4 and 5 which are my specifics)
- If you do a print again you shouldn't see the Free Space partitions.
- Exit parted
- Ctrl+Opt+F7 to get back to the installer GUI
- Proceed as normal. You shouldn't see any errors.

Another suggestion is to edit yaboot.conf and set the default delay=5 to 
something a little higher like delay=30.

Comment 16 Jeremy Katz 2005-08-15 14:46:00 EDT
*** Bug 165883 has been marked as a duplicate of this bug. ***
Comment 17 Rahul Sundaram 2005-09-05 01:31:04 EDT
*** Bug 163263 has been marked as a duplicate of this bug. ***
Comment 18 David Woodhouse 2005-09-28 07:15:32 EDT
Install images with this fixed can be found at
ftp://zeniv.uk.linux.org/pub/people/dwmw2/fc4-pegasos/
Comment 19 Paul Nasrat 2006-03-16 13:13:06 EST
*** Bug 185637 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.