Bug 1633127 - [Tectonic] Prometheus charts unit are wrong on Node page
Summary: [Tectonic] Prometheus charts unit are wrong on Node page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: 4.1.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1731202 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-26 09:03 UTC by XiaochuanWang
Modified: 2019-07-19 09:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, admin console memory graphs would show unit `B` rather than `G` for gigabytes usage. The problem has been fixed, and the charts will now show `G` as the unit.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
prometheus cart unit on openshift (64.69 KB, image/png)
2018-09-26 09:03 UTC, XiaochuanWang
no flags Details
prometheus data of memory (64.85 KB, image/png)
2018-09-26 09:05 UTC, XiaochuanWang
no flags Details
prometheus data of filesystem (53.52 KB, image/png)
2018-09-26 09:05 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:45 UTC

Description XiaochuanWang 2018-09-26 09:03:55 UTC
Created attachment 1487094 [details]
prometheus cart unit on openshift

Description of problem:
Cluster-admin check Node page, the charts of RAM memory and Filesystem are using wrong unit.

Version-Release number of selected component (if applicable):
openshift v3.11.15

How reproducible:
Always

Steps to Reproduce:
1. Cluster-admin check Node page, check the unit of RAM memory chart
2. Cluster-admin check Node page, check the unit of Filesystem chart

Actual results:
1 & 2. Both RAM and Filesystem unit are B


Expected results:
According to Prometheus side data. Both units should be G

Additional info:
Please refer to screenshots.

Comment 1 XiaochuanWang 2018-09-26 09:05:25 UTC
Created attachment 1487095 [details]
prometheus data of memory

Comment 2 XiaochuanWang 2018-09-26 09:05:56 UTC
Created attachment 1487096 [details]
prometheus data of filesystem

Comment 3 Samuel Padgett 2018-09-26 15:03:55 UTC
The data is accurate, but it's showing billions of bytes (B here is billions). 1 billion bytes is same as 1 GB.

We should change this, though, because it's not obvious at all.

Comment 5 Samuel Padgett 2019-03-22 18:31:42 UTC
https://github.com/openshift/console/pull/1323

Comment 7 XiaochuanWang 2019-03-26 05:52:26 UTC
Thanks for explain, it's easily confuse user whether the B is Billion or Bytes. Now it's all G and the chart data are reasonable displayed.
Verified on 4.0.0-0.nightly-2019-03-25-180911

Comment 9 errata-xmlrpc 2019-06-04 10:40:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758

Comment 10 Samuel Padgett 2019-07-19 09:11:52 UTC
*** Bug 1731202 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.