Bug 1731202 - RAM consumption in Operator Console has misleading unit
Summary: RAM consumption in Operator Console has misleading unit
Keywords:
Status: CLOSED DUPLICATE of bug 1633127
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 3.11.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-18 15:27 UTC by Simon Reber
Modified: 2019-07-19 09:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-19 09:11:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot from Pod Overview (35.90 KB, image/png)
2019-07-18 15:27 UTC, Simon Reber
no flags Details

Description Simon Reber 2019-07-18 15:27:28 UTC
Created attachment 1591823 [details]
Screenshot from Pod Overview

Description of problem:

In OpenShift Container Platform 3.11, the Operator (Cluster) Console shows misleading unit for the RAM graph.

Within the `Pod Overview` the unit for RAM is reported as `B` if the range is within GB range.

This is fairly misleading as it could also mean Byte or something else and does not properly reflect the GB unit.

Version-Release number of selected component (if applicable):

- openshift v3.11.98
- kubernetes v1.11.0+d4cacc0

How reproducible:

- Always

Steps to Reproduce:
1. Install OpenShift Container Platform 3.11 with Prometheus
2. Start pod
3. Check pod Overview in Cluster Console and verify the unit for RAM

Actual results:

Unit is set to 4B if the pod is using 4 GB

Expected results:

Unit should be set to 4GB if the pod is using 4 GB

Additional info:

Comment 1 Samuel Padgett 2019-07-19 09:11:52 UTC

*** This bug has been marked as a duplicate of bug 1633127 ***


Note You need to log in before you can comment on or make changes to this bug.