Bug 163415 - Kernel 2.6.12-1.1372_FC3 for x86_64 is missing headers
Kernel 2.6.12-1.1372_FC3 for x86_64 is missing headers
Status: CLOSED DUPLICATE of bug 163406
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-15 20:51 EDT by Brian Daniels
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 22:16:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Daniels 2005-07-15 20:51:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I did a 'yum update' this evening that installed kernel-2.6.12-1.1372_FC3 on my AMD64 system.  After the update I tried to install my Nvidia drivers, which failed due to missing kernel source. 

Previous kernel updates have created a build directory, i.e. 
/lib/modules/2.6.11-1.35_FC3/build that contains the needed headers.

The kernel-2.6.12-1.1372_FC3 created a symlink in /lib/modules/2.6.12-1.1372_FC3/:
build -> ../../../usr/src/kernels/2.6.12-1.1372_FC3-x86_64
which points to a nonexistent directory.

Without these headers, the drivers cannot be compiled.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
1. yum update to kernel-2.6.12-1.1372_FC3
2. look in /lib/modules/2.6.12-1.1372_FC3/
3. build directory has been replaced with a symlink
  

Actual Results:  build directory has been replaced with a symlink

Expected Results:  build directory should contain correct kernel headers

Additional info:
Comment 1 Dave Jones 2005-07-15 22:16:28 EDT

*** This bug has been marked as a duplicate of 163406 ***

Note You need to log in before you can comment on or make changes to this bug.