Bug 163406 - (fc3kerneldevel) FC3 contains backported kernel-devel packages from FC4.
FC3 contains backported kernel-devel packages from FC4.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 163410 163415 163551 163618 164016 164249 164496 165067 166896 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-15 17:45 EDT by Gerald Thompson
Modified: 2015-01-04 17:20 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 21:53:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Thompson 2005-07-15 17:45:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
after installing kernel-2.6.12-1.1372_FC3 for i686
1.  the driver for HP Laserjet 5L seems to be missing,
2.  kernel source modules cannot be found for kernel-2.6.12-1.1372_FC3
- when I checked the link for /lib/modules/2.6.12-1.1372_FC3/build it reported /lib/modules/2.6.12-1.1372_FC3/build
- when I checked the link for /lib/modules/2.6.12-1.1372_FC3/source it reported /lib/modules/2.6.12-1.1372_FC3/source
- in both cases those locations report back as a symlink redirecting to themselves with no data in the directories.


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
after installing kernel-2.6.12-1.1372_FC3 for i686
1.  the driver for HP Laserjet 5L seems to be missing, kudzu said that I needed to remove the hardware HP Laserjet 5L, which I did.  It did not add the printer back.  I tried restarting and kudzu did not detect that it had an available driver/module for HP Laserjet 5L while running kernel-2.6.12-1.1372_FC3
- I restarted and booted up in kernel-2.6.11-1.35_FC3 - the hp laserjet 5l was detected by kudzu and installed, no issues.

2.  kernel source modules cannot be found for kernel-2.6.12-1.1372_FC3
- after installing the kernel I restarted the computer
- of course the nvidia module and vmware modules were not working because of the new kernel
- I confirmed that I didn't want x to try starting anymore
- logged in as root
- telinit 3
- when I tried to run vmware-config.pl or nvidia-installer they were both unable to find the kernel source and libraries in order to build new modules for the new kernel
- now in all the older kernels the source was found in /lib/modules/"kernel version number"/build/include
- when you go into my old kernel folder /lib/modules/2.6.11-1.35_FC3/build all the files are there
- when I went into new kernel folder /lib/modules/2.6.12-1.1372_FC3 both the build and source directories were symlinked.  The thing is they were symlinked back to themselves, like a weird loop.
- when I checked the link for /lib/modules/2.6.12-1.1372_FC3/build it reported /lib/modules/2.6.12-1.1372_FC3/build
- when I checked the link for /lib/modules/2.6.12-1.1372_FC3/source it reported /lib/modules/2.6.12-1.1372_FC3/source
- in both cases those locations report back as a symlink redirecting to themselves with no data in the directories.


Actual Results:  1. unable to find a driver module for HP Laserjet 5L printer
2. you cannot build third party modules because the kernel source and libraries cannot be found in the expected locations
- when I checked the link for /lib/modules/2.6.12-1.1372_FC3/build it reported /lib/modules/2.6.12-1.1372_FC3/build
- when I checked the link for /lib/modules/2.6.12-1.1372_FC3/source it reported /lib/modules/2.6.12-1.1372_FC3/source
- in both cases those locations report back as a symlink redirecting to themselves with no data in the directories.

Expected Results:  when I boot into the old kernel-2.6.11-1.35_FC3 I do not have this issue
1. under the kernel-2.6.11-1.35_FC3 the HP Laserjet 5L is detected by kudzu and installed, and works properly
2. under the kernel-2.6.11-1.35_FC3 when you try to build a 3rd party module like vmware or nvidia the source files are found /lib/modules/2.6.11-1.35_FC3/build

Additional info:
Comment 1 Dave Jones 2005-07-15 18:31:46 EDT
the laserjet issue is probably a dupe of #153252
Lets keep this bug focused on the kernel source issue.

I screwed up, and backported the FC4 kernel-devel changes to the FC3 update.
There's currently debate on fedora-list about whether to change back to the
old-style or not.
Comment 2 Dave Jones 2005-07-15 19:16:49 EDT
*** Bug 163410 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2005-07-15 22:16:39 EDT
*** Bug 163415 has been marked as a duplicate of this bug. ***
Comment 7 Warren Togami 2005-07-18 16:12:34 EDT
*** Bug 163551 has been marked as a duplicate of this bug. ***
Comment 8 Gilles Detillieux 2005-07-19 12:54:33 EDT
While the FC4 kernel packaging model makes a lot of sense, I think it's a bad
idea to change packaging models mid-stream for the FC3 distribution.  It breaks
the dependencies that may have been established for other 3rd party packages
that include kernel modules.  A package that depended only on "kernel" for FC3
before, suddenly must be dependent on "kernel-devel" too, but only if the kernel
release is >= 2.6.12-1.1372_FC3.  Even if you could easily deal with that in a
package's .spec file, it still breaks packages that include kernel modules that
were packaged before the kernel update.

Or, to put it another way, it's still a bug.  Errata updates within an
established distribution shouldn't cause this much upheaval.  Changing packaging
models, regardless of how much of an improvement the new model might be, should
be left for new distributions.

Having said that, now that a lot of FC3 users have installed kernel-devel, you
shouldn't just yank it away either in the next kernel update, unless the new
kernel package somehow overrides or obsoletes kernel-devel.  But will doing that
cause grief when upgrading from FC3 to FC4?  Hmmmmm...
Comment 9 Warren Togami 2005-07-19 16:20:27 EDT
*** Bug 163618 has been marked as a duplicate of this bug. ***
Comment 10 Dmitry Butskoy 2005-07-21 11:26:27 EDT
  Completely agree with comment #8 .

  There are a lot of people who use FC in the production environment -- where
would be better to use RHEL, but due to some reasons (absence of money, etc.) FC
is used.
  Unfortunately, unlike RHEL, FC is unstable enough. Don`t add superfluous
"instability" by sudden change of the scheme of kernel packages...
Comment 11 Warren Togami 2005-07-22 18:08:51 EDT
*** Bug 164016 has been marked as a duplicate of this bug. ***
Comment 12 Dave Jones 2005-07-28 02:32:39 EDT
*** Bug 164249 has been marked as a duplicate of this bug. ***
Comment 13 Dave Jones 2005-07-28 14:56:02 EDT
*** Bug 164496 has been marked as a duplicate of this bug. ***
Comment 14 Dave Jones 2005-07-28 17:51:49 EDT
The -devel changes have been backed out in CVS. The next update will revert to
the original FC3 behaviour.
Comment 15 Dave Jones 2005-08-04 00:14:25 EDT
*** Bug 165067 has been marked as a duplicate of this bug. ***
Comment 16 Dmitry Butskoy 2005-08-10 08:27:42 EDT
  The new kernel has appeared in updates/testing/3 ...
  But there is no kernel-smp-*-i586 . Such build is already excluded from FC4,
but if it has been included in FC3, it should be supported while FC3 is
supported. Otherwise there is a probability that someone using this kernel
(including by mistake :-)) and hoping to receive updates from a usual place,
will not receive any more kernel updates.
Comment 17 Dave Jones 2005-08-26 19:56:48 EDT
*** Bug 166896 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.