Bug 163442 - after upgrade from fc3, greek file names are replaced by ????
after upgrade from fc3, greek file names are replaced by ????
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
wrong apearence of greek fonts
:
: 163687 163690 163737 164093 164135 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-16 15:46 EDT by Kyriakos Kachrimanis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 10:33:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyriakos Kachrimanis 2005-07-16 15:46:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Description of problem:
After I upgraded from FC3 to FC4, all greek letters in file names have been replaced by "?". It seems impossible to install greek language support.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.upgrade from fc3 to fc4
2.open a folder containing files with greek names
3.greek letters are replaced by "?" marks
  

Actual Results:  greek letters are replaced by "?" marks

Expected Results:  greek letters should appear normal

Additional info:
Comment 1 Chris Lumens 2005-07-18 10:41:15 EDT
What are the contents of /etc/sysconfig/i18n?  What is your $LANG set to?
Comment 2 Kyriakos Kachrimanis 2005-07-18 13:56:31 EDT
(In reply to comment #1)
> What are the contents of /etc/sysconfig/i18n?  What is your $LANG set to?

the comments of i18n are:

LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en"
SYSFONT="latarcyrheb-sun16"

and $LANG produces the output:

[root@Lakonia ~]# $LANG
bash: en_US.UTF-8: command not found
[root@Lakonia ~]#
Comment 3 Chris Lumens 2005-07-20 10:12:44 EDT
*** Bug 163687 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2005-07-20 10:12:51 EDT
*** Bug 163690 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2005-07-20 15:07:18 EDT
*** Bug 163737 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2005-07-25 10:03:19 EDT
*** Bug 164093 has been marked as a duplicate of this bug. ***
Comment 7 Chris Lumens 2005-07-25 10:04:07 EDT
*** Bug 164135 has been marked as a duplicate of this bug. ***
Comment 8 Chris Lumens 2005-07-25 10:05:46 EDT
It appears you are probably reloading the submission page over and over again to
check for status updates, but this is resulting in the bug getting posted
multiple times.  Please search for the bug number (163442) instead to see
updates so that duplicates will not get submitted.
Comment 9 Alexander Larsson 2006-09-04 10:33:48 EDT
FC4 uses utf8 filenames by default. Its likely your old files are encoded in
another encoding. 

You can set the environment variable G_BROKEN_FILENAMES to use locale encoded
filenames, however, it seems your locale is utf8, so you would also have to
change the locale encoding.

Note You need to log in before you can comment on or make changes to this bug.