Bug 1635405 - Move Disk dialog keeps spinning - API method works
Summary: Move Disk dialog keeps spinning - API method works
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.3.0
: 4.3.0
Assignee: shani
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks: 1646992
TreeView+ depends on / blocked
 
Reported: 2018-10-02 20:29 UTC by Javier Coscia
Modified: 2020-08-03 15:34 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.3.0_alpha
Doc Type: Bug Fix
Doc Text:
This release adds a log entry at the WARN level if an attempt is made to move a disk with a damaged ancestor. A workaround solution is to leverage the REST API to move the disk between storage domains.
Clone Of:
: 1646992 (view as bug list)
Environment:
Last Closed: 2019-05-08 12:38:40 UTC
oVirt Team: Storage
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1585662 0 unspecified CLOSED NPE in admin portal when trying to migrate a disk to another SD 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1641326 0 unspecified CLOSED NPE while querying for an ancestor image with no entry on 'images' table 2021-02-22 00:41:40 UTC
Red Hat Knowledge Base (Solution) 3639731 0 None None None 2018-10-04 19:35:53 UTC
Red Hat Product Errata RHEA-2019:1085 0 None None None 2019-05-08 12:38:53 UTC
oVirt gerrit 94992 0 master MERGED core: Fix UI for moving a disk with a damaged ancestor 2020-02-25 12:38:42 UTC
oVirt gerrit 95266 0 ovirt-engine-4.2 MERGED core: Fix UI for moving a disk with a damaged ancestor 2020-02-25 12:38:42 UTC

Internal Links: 1585662 1641326

Description Javier Coscia 2018-10-02 20:29:58 UTC
Description of problem:

When trying to move disks from UI, the dialog keeps spinning and ui.log 
throws a JavaScriptException: 'Cannot read property 'G' of null'



Version-Release number of selected component (if applicable):

rhvm-4.2.5.4-0.1.el7ev
vdsm-4.20.35-1.el7ev

How reproducible:

100 % in customer's environment

Steps to Reproduce:
1. Get a working VM based on a template
2. Click on the 'Move' button in UI


Actual results:

Move Disks dialog keeps spinning and does not provide any information

Expected results:

Dialog should pop-up and let you continue with disk move flow


Additional info:

The VM had 2 snapshots referenced in DB, 1 for Live Storage migration which
didn't exist or is not associated to any volume



Workaround:
===========

Use the API to move the disk between storage domains

~~~
curl \
--cacert '/etc/pki/ovirt-engine/ca.pem' \
--user '$USER@$DOMAIN:$PASS' \
--request POST \
--header 'Version: 4' \
--header 'Content-Type: application/xml' \
--header 'Accept: application/xml' \
--data '
<action>
  <storage_domain id="$sdUUID"/>
</action>
' \
https://$ENGINE-FQDN/ovirt-engine/api/disks/$imgUUID/move
~~~

Comment 21 Raz Tamir 2018-11-26 16:06:16 UTC
Verified as this is not reproducing in 4.3.0-0.5.alpha1.el7

Comment 22 RHV bug bot 2018-12-10 15:12:40 UTC
WARN: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 23 RHV bug bot 2019-01-15 23:35:03 UTC
WARN: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 25 errata-xmlrpc 2019-05-08 12:38:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085

Comment 26 Daniel Gur 2019-08-28 13:12:35 UTC
sync2jira

Comment 27 Daniel Gur 2019-08-28 13:16:48 UTC
sync2jira


Note You need to log in before you can comment on or make changes to this bug.