Bug 1646992 - [downstream clone - 4.2.8] Move Disk dialog keeps spinning - API method works
Summary: [downstream clone - 4.2.8] Move Disk dialog keeps spinning - API method works
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.8
: ---
Assignee: shani
QA Contact: Yosi Ben Shimon
URL:
Whiteboard:
Depends On: 1635405
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-06 13:25 UTC by RHV bug bot
Modified: 2020-08-03 15:28 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.2.8.1
Doc Type: Bug Fix
Doc Text:
This fix addresses the attempt to move a disk with a damaged ancestor (e.g., the ancestor doesn't have an entry in the 'images' table), which leads to an NPE and an error. If the error persists, a possible workaround is to use the API to move the disk between storage domains. The fix documents the error in the Red Hat Virtualization Manager log.
Clone Of: 1635405
Environment:
Last Closed: 2019-01-22 12:44:50 UTC
oVirt Team: Storage
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3639731 0 None None None 2018-11-06 13:27:16 UTC
Red Hat Product Errata RHBA-2019:0121 0 None None None 2019-01-22 12:45:01 UTC
oVirt gerrit 94992 0 master MERGED core: Fix UI for moving a disk with a damaged ancestor 2018-11-06 13:27:16 UTC
oVirt gerrit 95266 0 ovirt-engine-4.2 MERGED core: Fix UI for moving a disk with a damaged ancestor 2018-11-06 13:27:16 UTC

Description RHV bug bot 2018-11-06 13:25:59 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1635405 +++
======================================================================

Description of problem:

When trying to move disks from UI, the dialog keeps spinning and ui.log 
throws a JavaScriptException: 'Cannot read property 'G' of null'



Version-Release number of selected component (if applicable):

rhvm-4.2.5.4-0.1.el7ev
vdsm-4.20.35-1.el7ev

How reproducible:

100 % in customer's environment

Steps to Reproduce:
1. Get a working VM based on a template
2. Click on the 'Move' button in UI


Actual results:

Move Disks dialog keeps spinning and does not provide any information

Expected results:

Dialog should pop-up and let you continue with disk move flow


Additional info:

The VM had 2 snapshots referenced in DB, 1 for Live Storage migration which
didn't exist or is not associated to any volume



Workaround:
===========

Use the API to move the disk between storage domains

~~~
curl \
--cacert '/etc/pki/ovirt-engine/ca.pem' \
--user '$USER@$DOMAIN:$PASS' \
--request POST \
--header 'Version: 4' \
--header 'Content-Type: application/xml' \
--header 'Accept: application/xml' \
--data '
<action>
  <storage_domain id="$sdUUID"/>
</action>
' \
https://$ENGINE-FQDN/ovirt-engine/api/disks/$imgUUID/move
~~~

(Originally by Javier Coscia)

Comment 22 Yosi Ben Shimon 2018-12-11 13:04:16 UTC
Tested using :
ovirt-engine-4.2.8-0.1.el7ev.noarch

I didn't manage to reproduce it eighter.
No errors found in logs (engine & VDSM) and browser developer console.

Moving to VERIFIED.

Comment 24 errata-xmlrpc 2019-01-22 12:44:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0121

Comment 25 Daniel Gur 2019-08-28 13:14:08 UTC
sync2jira

Comment 26 Daniel Gur 2019-08-28 13:18:25 UTC
sync2jira


Note You need to log in before you can comment on or make changes to this bug.