Bug 1635973 - Linker failure with duplicate symbols
Summary: Linker failure with duplicate symbols
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtbase
Version: 29
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1640914 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-04 06:51 UTC by Pier Luigi Fiorini
Modified: 2018-11-03 00:01 UTC (History)
10 users (show)

Fixed In Version: qt5-qtbase-5.11.1-9.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-03 00:01:07 UTC


Attachments (Terms of Use)

Description Pier Luigi Fiorini 2018-10-04 06:51:09 UTC
Description of problem:

I'm building packages with COPR, targeting Fedora 29 but the build fails with the following linker error:

compiling color.cpp [fluidcontrolsplugin]
linking fluid-demo [fluid-demo]
compiling moc_controlsutils.cpp [fluidcontrolsplugin]
BUILDSTDERR: ERROR: /usr/bin/g++ -Wl,-m,elf_i386 -m32 -o /builddir/build/BUILD/fluid-8d3c34738e63a1bde8d9d95f4e1f93c8ad93ccb7/build/default/fluid-demo.621c3a4a/fluid-demo /builddir/build/BUILD/fluid-8d3c34738e63a1bde8d9d95f4e1f93c8ad93ccb7/build/default/fluid-demo.621c3a4a/3a52ce780950d4d9/iconcategorymodel.cpp.o /builddir/build/BUILD/fluid-8d3c34738e63a1bde8d9d95f4e1f93c8ad93ccb7/build/default/fluid-demo.621c3a4a/3a52ce780950d4d9/iconnamemodel.cpp.o /builddir/build/BUILD/fluid-8d3c34738e63a1bde8d9d95f4e1f93c8ad93ccb7/build/default/fluid-demo.621c3a4a/3a52ce780950d4d9/main.cpp.o /builddir/build/BUILD/fluid-8d3c34738e63a1bde8d9d95f4e1f93c8ad93ccb7/build/default/fluid-demo.621c3a4a/3a52ce780950d4d9/qrc_fluid-demo.cpp.o /builddir/build/BUILD/fluid-8d3c34738e63a1bde8d9d95f4e1f93c8ad93ccb7/build/default/fluid-demo.621c3a4a/73489b871e127538/moc_iconcategorymodel.cpp.o /builddir/build/BUILD/fluid-8d3c34738e63a1bde8d9d95f4e1f93c8ad93ccb7/build/default/fluid-demo.621c3a4a/73489b871e127538/moc_iconnamemodel.cpp.o /usr/lib/libQt5QuickControls2.so.5.11.1 /usr/lib/libQt5Quick.so.5.11.1 /usr/lib/libQt5Qml.so.5.11.1 /usr/lib/libQt5Network.so.5.11.1 /usr/lib/libQt5Gui.so.5.11.1 /usr/lib/libQt5Core.so.5.11.1
BUILDSTDERR: ERROR: /usr/bin/ld: //lib/libQt5QuickTemplates2.so.5:(*IND*+0x0): multiple definition of `_end'
BUILDSTDERR: /usr/bin/ld: //lib/libQt5QuickTemplates2.so.5:(*IND*+0x0): multiple definition of `_edata'
BUILDSTDERR: collect2: error: ld returned 1 exit status
BUILDSTDERR: ERROR: Process failed with exit code 1.
BUILDSTDERR: The following products could not be built for configuration default:
BUILDSTDERR: fluid-demo, fluidcontrolsplugin, fluidcoreplugin

This looks like this F28 issue: https://bugzilla.redhat.com/show_bug.cgi?id=1458003

I can reproduce the issue on both i386 and x86_64

Comment 1 Nick Clifton 2018-10-09 15:03:31 UTC
Hi Pier,

  Are you using the gold linker ?  If so, as a workaround, you could try
  using the bfd linker instead.

  In the meantime, are you able to put together a tarball of the object
  files and libraries, so that I can try linking them locally ?

Cheers
  Nick

Comment 2 Pier Luigi Fiorini 2018-10-11 10:32:05 UTC
Nope I didn't use the gold linker, but it seems qt5-qtbase does:

https://src.fedoraproject.org/rpms/qt5-qtbase/c/507fe0eddd60a68c2e1537113a761a2ed201fb3a?branch=master

That's why I also CC'ed Rex.

It will take a me some time before I can send you the object files and libraries, because I don't have F29 installed (the build is from COPR).

Comment 3 Rex Dieter 2018-10-11 13:15:31 UTC
OK, perhaps it's time to switch Qt5 stack away from gold (again).

Comment 4 Pier Luigi Fiorini 2018-10-22 06:02:33 UTC
Now that you have disable gold on Rawhide my builds are green.
Could you apply your patch to 29 too?

Comment 6 Pier Luigi Fiorini 2018-10-24 12:43:08 UTC
*** Bug 1640914 has been marked as a duplicate of this bug. ***

Comment 7 Rex Dieter 2018-10-24 13:19:37 UTC
I was originally planning on bringing this fix along with the rest of qt 5.9.2 , but that will likely take longer.

I'll go ahead and do it now.

Comment 8 Fedora Update System 2018-10-24 20:57:16 UTC
qt5-qtbase-5.11.1-8.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1fdfed503a

Comment 9 Rex Dieter 2018-10-24 20:58:34 UTC
also just submitted buildroot override for qt5-qtbase-5.11.1-8.fc29 , to allow builds to use it for a week (expires Oct 31).

Comment 10 Pier Luigi Fiorini 2018-10-25 06:57:16 UTC
Made a F29 VM, updated qt5-qtbase from the new build:

$ rpm -qa | grep qt5-qtbase
qt5-qtbase-common-5.11.1-8.fc29.noarch
qt5-qtbase-5.11.1-8.fc29.x86_64
qt5-qtbase-devel-5.11.1-8.fc29.x86_64
qt5-qtbase-gui-5.11.1-8.fc29.x86_64

but still the same linker issue.

Perhaps qt5-qtquickcontrols2 needs to be rebuilt as well?

Comment 11 Fedora Update System 2018-10-25 15:37:43 UTC
qt5-qtbase-5.11.1-8.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1fdfed503a

Comment 12 Fedora Update System 2018-10-25 19:46:40 UTC
qt5-qtbase-5.11.1-8.fc29 qt5-qtquickcontrols2-5.11.1-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1fdfed503a

Comment 13 Pier Luigi Fiorini 2018-10-25 20:03:08 UTC
it works with qt5-qtquickcontrols2-5.11.1-3.fc29, thanks.

Comment 14 Fedora Update System 2018-10-31 18:48:40 UTC
qt5-qtbase-5.11.1-9.fc29, qt5-qtquickcontrols2-5.11.1-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1fdfed503a

Comment 15 Fedora Update System 2018-11-03 00:01:07 UTC
qt5-qtbase-5.11.1-9.fc29, qt5-qtquickcontrols2-5.11.1-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.