Bug 163638 - Korean Input Method AMI doesn't work without desktop specification
Korean Input Method AMI doesn't work without desktop specification
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xinitrc (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Jay Turner
:
Depends On:
Blocks: RHEL3U8MustFix 185486 190797 190798 190799
  Show dependency treegraph
 
Reported: 2005-07-19 14:55 EDT by David Milburn
Modified: 2015-01-07 19:10 EST (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2006-0475
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 10:23:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to correct problem. (542 bytes, patch)
2005-07-19 15:08 EDT, David Milburn
no flags Details | Diff

  None (edit)
Description David Milburn 2005-07-19 14:55:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Korean Input Method AMI doesn't work without desktop specification.
If the system has both KDE and GNOME, AMI launches with a wrong option.



Version-Release number of selected component (if applicable):
xinitrc-3.32-1

How reproducible:
Always

Steps to Reproduce:
1. Setup RHEL3 with Korean environment.
   If it's necessary, create "~/.i18n" file containing "LANG=ko_KR".
2. Install both GNOME and KDE.
3. If "/etc/sysconfig/desktop" is exists, delete it (or change the name).
   This file was created at installation for graphical login.
   So, the file doesn't exist in some servers which don't have a graphical
   console.
4. Start X from console (or connect via XDM).
   $ startx
5. Open a terminal. e.g. gnome-terminal.
6. Press shift+space to activate AMI.

  

Actual Results:  AMI cannot turned on. Nothing happen.
It looks AMI is waiting something forever.


Expected Results:  AMI should turn on.
AMI should work with the default setting.


Additional info:

Information supplied by customer:

1. On KDE, AMI should launch by "wmami -wait" command.
   On GNOME, AMI should launch by "ami" command.
2. If "/etc/sysconfig/desktop" doesn't exist, "/etc/X11/xinit/xinitrc.d/xinput"
   always launch AMI for KDE setting.
3. AMI's KDE setting doesn't work on GNOME.

It looks "/etc/X11/xinit/Xclients" gave priority to GNOME.
On the other hand "/etc/X11/xinit/xinitrc.d/xinput" gave priority to KDE.
Comment 1 David Milburn 2005-07-19 15:08:19 EDT
Created attachment 116941 [details]
Patch to correct problem.
Comment 3 Mike A. Harris 2005-08-31 16:43:59 EDT
Need to check if this is a problem in RHEL4 also, and clone this
bug for RHEL4 if needed, so we can fix it in both places at once.
Also should be checked in CVS head xinitrc.
Comment 4 Mike A. Harris 2005-09-23 19:33:55 EDT
Please test if this problem occurs in RHEL4 also, as the xinitrc scripts
changed a lot between RHEL3 and RHEL4, and visual inspection does not
appear to be useable for determining if RHEL 4 is also affected.

Comment 13 David Lawrence 2006-04-25 12:50:07 EDT
Adding blocker bug 185486 and IBM group per request by John Jarvis.
Comment 16 David Lawrence 2006-04-27 13:17:26 EDT
Mistakenly added to IBM group, removing.
Comment 22 Mike A. Harris 2006-05-05 04:39:22 EDT
(In reply to comment #5)
> Bug fix checked into xinitrc-rhel3-branch branch of xinitrc CVS, new build
> xinitrc-3.32.1-1 created at branch point.  New xinitrc src.rpm checked into
> cvs.dist in RHEL-3 branch, but not built yet.
> 
> Status:  Waiting for RHEL3U7 development to begin, and for this bug to
> get triple-acked.  Once we've got the 3ACK, and the tree is open, I'll
> build this fix for U7.

Fix was already committed as per comment above.  Package now built for
RHEL3U8.

Comment 23 Mike A. Harris 2006-05-05 05:00:39 EDT
The identical problem was present in the Xclients script also via code
duplication, so I fixed that as well, since it is the exact same problem
with the exact same fix.
Comment 27 Red Hat Bugzilla 2006-07-20 10:23:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0475.html

Note You need to log in before you can comment on or make changes to this bug.