Bug 1636460 - mutter sometimes fails to unblank screen when unlocked by a user switch
Summary: mutter sometimes fails to unblank screen when unlocked by a user switch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter
Version: 7.4
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 7.7
Assignee: Jonas Ådahl
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 1489977
Blocks: 1571842 1607454 1656436 1707454 1588877 1597339 1632807 1635747 1640918
TreeView+ depends on / blocked
 
Reported: 2018-10-05 13:03 UTC by Ray Strode [halfline]
Modified: 2019-09-09 19:12 UTC (History)
14 users (show)

Fixed In Version: mutter-3.28.3-10.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1489977
Environment:
Last Closed: 2019-08-06 12:37:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME mutter merge_requests 543 None None None 2019-04-23 15:17:04 UTC
Red Hat Knowledge Base (Solution) 3559061 None None None 2018-10-05 13:03:48 UTC
Red Hat Product Errata RHBA-2019:2044 None None None 2019-08-06 12:38:19 UTC

Description Ray Strode [halfline] 2018-10-05 13:03:49 UTC
+++ This bug was initially created as a clone of Bug #1489977 +++
--- Additional comment from Jiri Koten on 2018-10-05 08:53:08 EDT ---

(In reply to Ray Strode [halfline] from comment #44)
> Created attachment 1490684 [details]
> this should fix it

I can confirm the fix worked for me. The login screen always starts when I switch user or logout.

The only issue I have found is that sometimes when I unlock the user session the screen remains blank and I have to move mouse to wake up the screen.

--- Additional comment from Ray Strode [halfline] on 2018-10-05 09:00:10 EDT ---

okay thats probably an unrelated issue in mutter.  lets clone that for 7.7

Comment 2 Jonas Ådahl 2019-03-26 14:54:46 UTC
I've been trying to reproduce this to no avail in a up to date 7.7 in a VM. Steps that have worked 10-20 times without any no-unblank issue:

1. Log in user A
2. Switch user via system menu
3. Login user B
4. Switch user via system menu
5. Goto 1.

Comment 3 Jonas Ådahl 2019-03-26 17:21:15 UTC
Same applies using Ctrl-Alt-F#. While switching back and forth, it hasn't failed to unblank.

Comment 4 Jiri Koten 2019-03-28 13:12:57 UTC
I can't reproduce in VM but I'm able to easily reproduce on my ThinkPad X1 Carbon 6th, but probably any laptop with intel GPU should be enough. I use Xorg and modesettings driver. After I unlock the user A, the screen remains blank.

Reproducer is the same as in c#2.

hw: 00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07)

Comment 5 Jiri Koten 2019-03-28 13:14:28 UTC
Tested with:

kernel-3.10.0-957.10.1.el7.x86_64
mutter-3.28.3-6.el7_6.x86_64
xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64

Comment 6 Jonas Ådahl 2019-04-12 14:00:11 UTC
Reproduced on Fedora, and came up with something that should fix it. At least I couldn't reproduce after this, but then again it only reproduced some times without it.

Scratch build available here: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=21154835

Jiri, could you test it?

Comment 7 Jiri Koten 2019-04-15 15:06:32 UTC
Didn't worked for me. I see cursor for a brief moment, but screen remains blank until I move mouse or use keyboard.

Comment 10 Jiri Koten 2019-06-14 11:17:21 UTC
Verified on the latest Snapshot compose.

Comment 12 errata-xmlrpc 2019-08-06 12:37:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2044


Note You need to log in before you can comment on or make changes to this bug.