Bug 1640918 - Switching users in GNOME session is starting new X servers for the user, and a user logout is making it unusable.
Summary: Switching users in GNOME session is starting new X servers for the user, and ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-qxl
Version: 7.6
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Default Assignee for SPICE Bugs
QA Contact: SPICE QE bug list
Marie Dolezelova
URL:
Whiteboard:
Depends On: 1489977 1635747 1636460
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-19 07:40 UTC by Jiri Koten
Modified: 2019-08-06 13:08 UTC (History)
20 users (show)

Fixed In Version: xorg-x11-drv-qxl-0.1.5-5.el7
Doc Type: Bug Fix
Doc Text:
.X.org server no longer crashes during fast user switching Previously, the X.Org X11 `qxl` video driver did not emulate the leaving virtual terminal event on shutdown. Consequently, the X.Org display server terminated unexpectedly during fast user switching, and the current user session was terminated when switching a user. With this update, `qxl` has been fixed, and the X.org server no longer crashes during fast user switching.
Clone Of: 1635747
Environment:
Last Closed: 2019-08-06 13:08:35 UTC


Attachments (Terms of Use)
backtrace (9.86 KB, text/plain)
2018-10-19 07:46 UTC, Jiri Koten
no flags Details
Xorg log (53.36 KB, text/plain)
2018-10-19 07:47 UTC, Jiri Koten
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2238 None None None 2019-08-06 13:08:38 UTC

Comment 1 Jiri Koten 2018-10-19 07:46:36 UTC
Created attachment 1495557 [details]
backtrace

Comment 2 Jiri Koten 2018-10-19 07:47:50 UTC
Created attachment 1495558 [details]
Xorg log

Comment 3 Victor Toso 2018-10-19 10:41:15 UTC
Easy to reproduce. I confirm that patch from Ray does fix the issue [0], I'll follow up with him how it should be proposed upstream.

https://bugzilla.redhat.com/attachment.cgi?id=1490121

Comment 5 Victor Toso 2018-10-25 07:59:10 UTC
Upstream merge request
https://gitlab.freedesktop.org/xorg/driver/xf86-video-qxl/merge_requests/2

Comment 14 Bill Sanford 2019-06-17 15:23:44 UTC
Verified with xorg-x11-drv-qxl-0.1.5-5.el7

Comment 16 errata-xmlrpc 2019-08-06 13:08:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2238


Note You need to log in before you can comment on or make changes to this bug.