Bug 163675 - mpeg situation not explained in documentation
mpeg situation not explained in documentation
Status: CLOSED ERRATA
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks: fc-relnotes-traqr
  Show dependency treegraph
 
Reported: 2005-07-20 04:35 EDT by Pepijn Schmitz
Modified: 2007-04-18 13:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 06:01:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pepijn Schmitz 2005-07-20 04:35:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The release notes of Fedore Core 4 (nor any other documentation, or any other version) don't explain the situation w.r.t. mpeg audio and Red Hat at all. MP3 support in many audio and video players is missing from FC4, as well as entire programs (JuK), and nowhere is it pointed out that this is the case, nor why it is the case.

The release notes should mention the fact that FC4 doesn't include mpeg audio support, explain why, and list the packages which are affected and in what way they are affected, so that people don't have to each individually spend hours finding out what's going on.

It would also be good (although I realise that this is the wrong place for that) if stubs were installed for the missing components which explain the situation. This has been done for xmms, but I think that's the only place. The other affected programs just display very generic and uninformative error messages, or they are just mysteriously missing.

All of this (I mean the missing explanation) is very customer-unfriendly at the least, and should be fixed, IMHO. It displays an arrogant disregard of time wasted by people trying to use FC4.

Version-Release number of selected component (if applicable):
n/a

How reproducible:
Always

Steps to Reproduce:
N/A

Additional info:
Comment 1 Elliot Lee 2005-07-20 17:27:23 EDT
test
Comment 2 Karsten Wade 2005-07-20 18:12:14 EDT
I'm sorry for the time you and other community members have lost.
That was not the point in our treatment of certain subjects within
Fedora documentation.

This FOSS project does not include non-free, closed-source, illegal,
or patent-infringing software in the distribution.  Fortunately, these
answers are highly available via Google and from sites such as
fedorafaq.org.  If you want to use software from a gray legal area,
that is your prerogative.  I'm sorry if it appears arrogant on the
part of the volunteer writers that we don't prioritize discussing
non-free software in the Fedora release notes.

One thing to keep in mind is that Fedora is a community project, so it
is impossible for anything in Fedora to be "customer-unfriendly".

The release notes were available throughout the test release process
for some months without this information you request.  That was the
best time to file a bug report asking for its inclusion.  Even one
such request might have been enough for us to reprioritize the
content.

However, it so happens that we -do- want to support all users in their
efforts to the best of our abilities, within the given constraints.
If our time had permitted more information in the release notes, we
would have done more.  We were busy getting relevent Fedora Core
information into the release notes.  We discussed links, e.g. to
http://fedorafaq.org and http://fedoraproject.org/wiki/ForbiddenItems,
but didn't have time to vet and include the list.

I'm leaving this bug in the queue as a reminder to get links to
explanatory text (i.e., the Wiki) in a near-future update of the
online release notes.
Comment 3 Pepijn Schmitz 2005-07-21 14:33:17 EDT
What a cop out.

First of all: just because your customers aren't paying you doesn't mean you can
treat them however you like.

Secondly: it would have been no trouble at all to include one tiny paragraph in
the release notes explaining all this. You make it sound like it would have cost
a team of writers months to do this.

Thirdly: this is not some obscure little "non-free, closed-source, illegal and
patent-infringing" piece of software. Missing MPEg audio playback functionality
is a sizable drawback for many people. Even Windows plays back MP3 files by
default. So do almost all other Linux distributions. It is something people
rightly expect, and at the very least it should be explained to them (by the
creators of the product, not by having them perform Google queries) that it is
missing, and why.

Lastly: don't blame me for this for not filing a bug about it during the test
process. As if nobody could have figured this out otherwise. And as if the
situation hasn't been the same for many previous versions.

What un unworthy response... Pity...
Comment 5 Paul W. Frields 2005-07-25 08:14:46 EDT
In response to each of the points in comment #3:

Firstly:  You're still acting like there's "customers" at all.  In a community
effort like Fedora, there's no such thing.  You are the provider and the
consumer, and so am I.  No one has treated anyone badly here, except for the way
you have accused people giving their VOLUNTEER efforts and time of having
"arrogant disregard."  I'm one of these community members too, and I give up a
large amount of time I could be spending with my wife and kids to instead devote
to this project, so people like you and I can benefit from it.  When you charge
in with this kind of attitude, it doesn't give folks like me a lot of reasons to
continue.  I don't work for Red Hat, and the only return I get out of this work
is knowing that (1) it will be the best it can be, and (2) other people will
benefit from it.

Secondly:  If you knew how fast and how hard we had to work to get the Release
Notes ready, mainly because there aren't enough people volunteering to help, you
would realize how completely ludicrous your suggestion is.  If this sort of
thing is important to you, you should be volunteering some time to HELP, instead
of just accusing other people of not keeping your personal priorities in mind. 
If you sign up on the docs list at
http://www.redhat.com/mailman/listinfo/fedora-docs-list I can promise you, this
bug notwithstanding, you will receive a warm welcome, and we could use the help.
 A community effort is based on what you give back, not what you expect to
happen without helping.

Thirdly:  I can tell from your statements here that you truly DO NOT UNDERSTAND
how licensing of MP3 or any other technology works.  What does Windows have to
do with Fedora?  Nothing.  Microsoft shells out millions of dollars to
Fraunhofer (the owner of the MP3 patents) so that they can ship MP3 codecs with
Windows.  Ogg Vorbis, a free product, is superior to MP3 in just about every
way, except market penetration, and that is increasing too.  You can find many
portable audio players that support it, including those made by iRiver, MPIO,
Sony, Samsung, and others.  I hear rumors that the Apple iPod will be updated to
handle it as well.  Why do we have to make excuses for not using inferior (and
non-free) software in Fedora?  Do you see any reason for us to apologize for not
including Microsoft Office in Fedora?  After all, many people expect to see that
on their computers, even though we have OpenOffice, which works just as well.

   It's nice that Karsten put up a brief statement in the Release Notes
concerning these things, but honestly, it's not too much to ask for people to
type "Fedora MP3" in Google and immediately have the answer.  (I notice that
both the #1 and #2 sites returned today both have answers to how to fix the
problem, if you are one of those people who gives lip service to free software
while you continue to use non-free stuff.)

Lastly:  When Red Hat removed MP3 support from its Red Hat Linux product at the
8.0 version, it posted the article at
http://www.redhat.com/speaks/speaks_80mm.html which explained the problem
briefly.  The issue of MP3 support is very old, and it is very well known
worldwide.  So old that most of us who have been using Linux for more than a
year or two don't really think about it anymore.  Don't blame us that you
couldn't get involved in the process for long enough to raise the issue in a
polite and helpful manner.

Karsten's response was cordial and restrained, while yours was mean-spirited and
caustic, and THAT is the true pity.  Please feel free to put a sock in it until
you can find a way to participate in this community in a constructive manner.
Comment 6 Rahul Sundaram 2005-08-29 06:01:23 EDT

The current errata includes the information demanded. Closing report

http://fedora.redhat.com/docs/release-notes/fc4/errata/index.html#sn-why-no-mp3

Note You need to log in before you can comment on or make changes to this bug.