Bug 16371 - Screen not refreshed properly on console switch
Summary: Screen not refreshed properly on console switch
Status: CLOSED DUPLICATE of bug 12611
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-16 16:23 UTC by David Balažic
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 17:41:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Balažic 2000-08-16 16:23:18 UTC
I experienced major problems when switching VTs on my pinstripe system,
involving X.

I have X 4.0.1 with the nv driver ( I have a TNT card ).

Example 1 :
Boot the system ( I have GNOME installed and run level 5 ) and wait
for the gdm login screen to appear. Switch to VT1, switch back to VT7.
The red hat logo in the background disappeared !

Example 2 : 
Switch to VT1 , log in as root and do "X :1".
You are now in an empty X screen on VT8. Switch to VT7
where a gdm login screen is ( you should not be logged in on VT7 ).
Notice how 99% of the gdm screen is gone ( replaced by that standard
black-and-white X background pattern ). The only parts left are the
picture of the GNOME logo ( the feet ) with the sign G-N-O-M-E under it
and the text filed for entering the user name.
Killing the server with ctrl-alt-backspace makes everything reappear
correctly.
Now switch to VT8. There should be the empty X screen , but it is entirely
black, with the mouse pointer being the only visible object.

This bug may be related to bugs 12611 and 15646

Comment 1 Mike A. Harris 2001-03-20 07:02:06 UTC

*** This bug has been marked as a duplicate of 12611 ***


Note You need to log in before you can comment on or make changes to this bug.