Bug 1637647 - [ibus-typing-booster] In gnome Wayland, while deleting with backspace, previously entered keywords appear repetitively in gedit.
Summary: [ibus-typing-booster] In gnome Wayland, while deleting with backspace, previo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mike FABIAN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-09 16:21 UTC by Bhushan Barve
Modified: 2020-03-16 20:29 UTC (History)
4 users (show)

Fixed In Version: ibus-typing-booster-2.8.1-1.fc30 ibus-typing-booster-2.8.1-1.fc31 ibus-typing-booster-2.8.1-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-08 00:08:26 UTC
Type: Bug


Attachments (Terms of Use)
deletion with backspace (214.10 KB, application/octet-stream)
2018-10-09 16:23 UTC, Bhushan Barve
no flags Details

Description Bhushan Barve 2018-10-09 16:21:11 UTC
Description of problem: Observed with wayland. Entered a sentence in gedit. After full stop, entered one more word. When tried deleting that keyword, observed that, after deletion, all the previously entered keywords in the last sentence were also appearing at the time of hitting backspace. Please see the attached screen-cast for reproducer. This is observed with gedit. Works as expected with gnome-terminal, oowriter etc.


Version-Release number of selected component (if applicable):
F29 workstation(2018-10-08)
[test@localhost ~]$ rpm -qa ibus-typing-booster
ibus-typing-booster-2.1.2-1.fc29.noarch
[test@localhost ~]$ rpm -qa ibus
ibus-1.5.19-4.fc29.x86_64
[test@localhost ~]$ rpm -qa gedit
gedit-3.30.1-2.fc29.x86_64

How reproducible:
always

Steps to Reproduce:
1. as above. 
2.
3.

Actual results:
While deleting with backspace, previously entered words are showing up repetitively. 

Expected results:
Backspace should delete the whole sentence without showing it repetitively. 

Additional info:
This works fine with xorg.

Comment 1 Bhushan Barve 2018-10-09 16:23:04 UTC
Created attachment 1492130 [details]
deletion with backspace

Comment 2 Mike FABIAN 2018-10-10 06:10:09 UTC
It works correctly in gedit in Gnome Xorg.

So this seems to be a problem in the surrounding text support in Gnome Wayland.

Comment 3 Mike FABIAN 2018-10-10 06:15:20 UTC
See also: https://bugzilla.redhat.com/show_bug.cgi?id=1625626

Comment 4 Mike FABIAN 2019-04-03 12:42:53 UTC
The bug still exists in Fedora 30.

Comment 5 Mike FABIAN 2019-12-03 07:56:32 UTC
The bug still exists in Fedora 31.

Comment 6 Fedora Update System 2020-02-27 18:20:33 UTC
FEDORA-2020-049620fad5 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-049620fad5

Comment 7 Fedora Update System 2020-02-27 18:22:15 UTC
FEDORA-2020-6ab69e189f has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-6ab69e189f

Comment 8 Fedora Update System 2020-02-27 18:25:14 UTC
FEDORA-2020-f5d026d0c5 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-f5d026d0c5

Comment 9 Fedora Update System 2020-02-28 01:27:35 UTC
ibus-typing-booster-2.8.1-1.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-049620fad5

Comment 10 Fedora Update System 2020-02-29 03:11:33 UTC
ibus-typing-booster-2.8.1-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-6ab69e189f

Comment 11 Fedora Update System 2020-02-29 03:59:53 UTC
ibus-typing-booster-2.8.1-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-f5d026d0c5

Comment 12 Fedora Update System 2020-03-08 00:08:26 UTC
ibus-typing-booster-2.8.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2020-03-08 00:51:06 UTC
ibus-typing-booster-2.8.1-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2020-03-16 20:17:05 UTC
ibus-typing-booster-2.8.1-1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2020-03-16 20:29:46 UTC
ibus-typing-booster-2.8.1-1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.