Bug 163820 - [kde] Writer crashed when inserting screenshot
[kde] Writer crashed when inserting screenshot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 165535 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-21 09:14 EDT by Linda Worthington
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.9.125-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 15:35:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linda Worthington 2005-07-21 09:14:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
While inserting a screenshot, png file, into a Writer document OpenOffice crashed with the following report:

0x340b0a: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db0a
0x341358: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e358
0xa3e420:  + 0x420 (__kernel_sigreturn + 0x0)
0xc09065: /usr/X11R6/lib/libX11.so.6 + 0x17065 (XCreatePixmap + 0xa5)
0x41eb007: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x20007
0x41ddbfa: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x12bfa
0x41de1db: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x131db
0x41de4c1: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x134c1
0x41de643: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x13643
0x41de6a5: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x136a5
0x33a2ad: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x172ad
0xbe3b80: /lib/libpthread.so.0 + 0x5b80
0xb3bdee: /lib/libc.so.6 + 0xcadee (__clone + 0x5e)



Version-Release number of selected component (if applicable):
OpenOffice 1.9.112

How reproducible:
Sometimes

Steps to Reproduce:
1.In open document click Insert > Picture > From file
2.Chose png file.
3.Right click on the png file > Picture > proceeded to change the size from 4.27 to 4.07.
  

Actual Results:  OpenOffice.org crashed and provided the above error report.

Expected Results:  Resize the file and proceed with document.

Additional info:
Comment 1 Caolan McNamara 2005-07-21 09:29:16 EDT
I bet you run under kde, should be fixed in todays update for FC4, 1.9.117-3 see
bug 162158

*** This bug has been marked as a duplicate of 162158 ***
Comment 2 Linda Worthington 2005-07-22 10:54:11 EDT
I updated FC4 to 1.9.117 yesterday and the problem has been fixed.  Thank you!!
Comment 3 Linda Worthington 2005-07-25 21:18:48 EDT
I am currently running 1.9.117 and I've just had another crash:

0x340b96: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db96
0x3413e4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3e4
0x83f420:  + 0x420 (__kernel_sigreturn + 0x0)
0x5340460: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xc1460
(Graphic::GetBitmap() const + 0x1e)
0xb5c11012: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x5c4012
0x5880e39: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0xf9e39
(TransferableHelper::getTransferData(com::sun::star::datatransfer::DataFlavor
const&) + 0x143)
0x488acc4: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x10cc4
0x488cc44: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x12c44
0x488d16b: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x1316b
0x488d451: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x13451
0x488d5d3: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x135d3
0x488d635: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x13635
0x33a339: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x17339
0xbe3b80: /lib/libpthread.so.0 + 0x5b80
0xb3bdee: /lib/libc.so.6 + 0xcadee (__clone + 0x5e)

I was removing an existing image in a Writer .sxw file and when I tried to place
a new image in the file, OOo crashed with the above message.

Comment 4 Linda Worthington 2005-07-25 22:04:36 EDT
I just tried to replace another image in Writer and received this error:

0x340b96: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db96
0x3413e4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3e4
0xcce420:  + 0x420 (__kernel_sigreturn + 0x0)
0x2b59fdc: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x1ffdc
0x2b4cb8a: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x12b8a
0x2b4d16b: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x1316b
0x2b4d451: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x13451
0x2b4d5d3: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x135d3
0x2b4d635: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x13635
0x33a339: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x17339
0xbe3b80: /lib/libpthread.so.0 + 0x5b80
0xb3bdee: /lib/libc.so.6 + 0xcadee (__clone + 0x5e)

I currently write for OOoAuthors and freelance for a company in Ireland that
supports OOo so I am a heavy user. 
Comment 5 Caolan McNamara 2005-07-28 09:56:41 EDT
This is reported fixed in the 1.9.121 version, there will be an update for FC4
reasonably soon. In the interim using the GNOME desktop instead of KDE would
workaround, or perhaps alternatively disabling klipper.
Comment 6 Linda Worthington 2005-07-28 10:52:15 EDT
I will try to disable klipper as GNOME has the same problem for me.  Thanks for
your time I really appreciate the help!  Looking forward to the 1.9.121.  Thanks
again!! :-)
Comment 7 Linda Worthington 2005-08-05 15:22:16 EDT
0x340b96: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db96
0x3413e4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3e4
0x9d2420:  + 0x420 (__kernel_sigreturn + 0x0)
0xc09065: /usr/X11R6/lib/libX11.so.6 + 0x17065 (XCreatePixmap + 0xa5)
0x28f9fdc: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x1ffdc
0x28ecb8a: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x12b8a
0x28ed16b: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x1316b
0x28ed451: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x13451
0x28ed5d3: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x135d3
0x28ed635: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x13635
0x33a339: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x17339
0xbe3b80: /lib/libpthread.so.0 + 0x5b80
0xb3bdee: /lib/libc.so.6 + 0xcadee (__clone + 0x5e)
Comment 8 Caolan McNamara 2005-08-05 16:13:51 EDT
Is that report from 1.9.121 or above ?, or still from the 1.9.117 version ?
Comment 9 Linda Worthington 2005-08-05 16:30:15 EDT
1.9.117 as 1.9.121 isn't in the channels for download.  I just ran up2date again
to make sure.

Thanks.
Comment 10 Caolan McNamara 2005-08-06 03:54:10 EDT
yeah, I believe it fixed in 1.9.121, i.e. "rawhide", soon there will be a beta2
for OOo and a update for fc4 will be pushed. In the meantime I can only suggest
using GNOME and not KDE :-)
Comment 11 Caolan McNamara 2005-08-10 05:50:51 EDT
*** Bug 165535 has been marked as a duplicate of this bug. ***
Comment 12 Linda Worthington 2005-08-10 21:35:40 EDT
OOo 1.9.117

0x340b96: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db96
0x3413e4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3e4
0x87b420:  + 0x420 (__kernel_sigreturn + 0x0)
0xb61acf52: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x166f52
(SwEditShell::GetAttr(SfxItemSet&) const + 0xb2)
0xb61af4ce: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1694ce
(SwEditShell::GetCurCharFmt() const + 0x32)
0xb65c8c50: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x582c50
(SwDocShell::StateStyleSheet(SfxItemSet&, SwWrtShell*) + 0x174)
0xb6640600: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x5fa600
0xb664061a: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x5fa61a
0x158e0ea: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1960ea
0x158bd80: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x193d80
(SfxDispatcher::_FillState(SfxSlotServer const&, SfxItemSet&, SfxSlot const*) +
0x54)
0x1598034: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a0034
0x1598288: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a0288
0x1598432: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a0432
0x5e225a2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x825a2
0x5e2e13e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e13e
(Timer::Timeout() + 0x10)
0x5e2e4b8: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e4b8
0xebdfe5: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3efe5
0xebdfd0: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3efd0
(SalData::Timeout() const + 0x24)
0x2f8352: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa352
0xe1af06: /usr/lib/libglib-2.0.so.0 + 0x24f06
0xe193ee: /usr/lib/libglib-2.0.so.0 + 0x233ee (g_main_context_dispatch + 0x1dc)
0xe1c3f6: /usr/lib/libglib-2.0.so.0 + 0x263f6
0xe1c8d8: /usr/lib/libglib-2.0.so.0 + 0x268d8 (g_main_context_iteration + 0x66)
0x2f8535: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa535
0xec4da1: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45da1
(X11SalInstance::Yield(unsigned char) + 0x29)
0x5e2891c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8891c
(Application::Yield() + 0x50)
0x5e2895a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8895a
(Application::Execute() + 0x26)
0x8065670: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1d670
(desktop::Desktop::Main() + 0x149a)
0x5e2dd49: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8dd49 (SVMain()
+ 0x45)
0x8060723: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18723 (sal_main +
0x47)
0xa85de6: /lib/libc.so.6 + 0x14de6 (__libc_start_main + 0xc6)
0x8060659: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18659
(Window::RequestHelp(HelpEvent const&) + 0x31)
Comment 13 Linda Worthington 2005-08-10 21:45:13 EDT
The new crash happened after inserting a screenshot then trying to format text
into a numbered list. 

KDE
Comment 14 Ralf Kleineisel 2005-08-11 04:02:19 EDT
This bug disappeared for me after upgrading all FC4 RPMS in updates-relased
(including kernel, glibc etc).
Comment 15 Linda Worthington 2005-08-12 22:51:27 EDT
I am running the most current kernel and updates.  I check a few times a day for
any updates available in the channels.  The only difference is I am running the
up2date release of OOo.
Comment 16 Linda Worthington 2005-08-13 05:19:42 EDT
0x340b96: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db96
0x3413e4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3e4
0x955420:  + 0x420 (__kernel_sigreturn + 0x0)
0x5e61460: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xc1460
(Graphic::GetBitmap() const + 0x1e)
0xb6684012: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x5c4012
0x6648e39: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0xf9e39
(TransferableHelper::getTransferData(com::sun::star::datatransfer::DataFlavor
const&) + 0x143)
0x2575cc4: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x10cc4
0x2577c44: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x12c44
0x257816b: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x1316b
0x2578451: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x13451
0x25785d3: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x135d3
0x2578635: /usr/lib/openoffice.org2.0/program/libdtransX11680li.so + 0x13635
0x33a339: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x17339
0xbe3b80: /lib/libpthread.so.0 + 0x5b80
0xb3bdee: /lib/libc.so.6 + 0xcadee (__clone + 0x5e)
Comment 17 Caolan McNamara 2005-08-24 07:28:54 EDT
there's now a testing update to 1.9.125 for fc4 which I hope will fix this.

e.g.
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/4/i386/ 
Comment 18 Caolan McNamara 2005-08-26 15:35:04 EDT
1.9.125-1 pushed for fc4, should be fixed in that version
Comment 19 Linda Worthington 2005-08-26 17:30:59 EDT
Thanks for all the help and your hard work!! I am downloading the update now.

Note You need to log in before you can comment on or make changes to this bug.