Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1638336

Summary: Uploading default plan from GUI is wrong
Product: Red Hat OpenStack Reporter: Andrey Fiodorov <afiodoro>
Component: openstack-tripleo-uiAssignee: RHOS Maint <rhos-maint>
Status: CLOSED DUPLICATE QA Contact: Andrey Fiodorov <afiodoro>
Severity: high Docs Contact:
Priority: unspecified    
Version: 14.0 (Rocky)CC: flfuchs, jjoyce, jschluet, jtomasek, slinaber, tvignaud
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-01 14:09:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Andrey Fiodorov 2018-10-11 11:02:09 UTC
Description of problem:
When we trying to import a plan from GUI and use the first option of Type for uploading we getting error.

Version-Release number of selected component (if applicable):
openstack-tripleo-ui-9.3.1-0.20180921180341.df30b55.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install OSP14
2. Go to GUI > Plans
3. Click on "Import Plan" then set the name for the plan and choose "Upload Type" - Use Default Templates and click on "Upload Files and Create Plan".

Actual results:
ERROR:
Plan creation failed The action raised an exception [action_ex_id=5de4f980-f26b-44c1-9311-5c6f2a28465f, action_cls='<class 'mistral.actions.action_factory.UploadTemplatesAction'>', attributes='{}', params='{u'container': u'overcloud-imported'}'] Unexpected error while running command. Command: /usr/bin/tar -C /usr/share/openstack-tripleo-heat-templates/ -czf /tmp/tmpWwNfr6 --exclude .git --exclude .tox --exclude *.pyc --exclude *.pyo . Exit code: 2 Stdout: u'' Stderr: u'/usr/bin/tar: /usr/share/openstack-tripleo-heat-templates/: Cannot open: No such file or directory\n/usr/bin/tar: Error is not recoverable: exiting now\n'

Expected results:


Additional info:
I think it happens because the mistral in the container and can't run this command from container. (/usr/bin/tar -C /usr/share/openstack-tripleo-heat-templates/ -czf /tmp/tmpWwNfr6 --exclude .git --exclude .tox --exclude *.pyc --exclude *.pyo .)

Comment 2 Florian Fuchs 2018-11-01 14:09:22 UTC
This is one part of the problem described here: https://bugzilla.redhat.com/show_bug.cgi?id=1636746

I'll set it as duplicate of the above BZ.

*** This bug has been marked as a duplicate of bug 1636746 ***