Bug 163896 - at: Should support -r besides -d
at: Should support -r besides -d
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: at (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Mike McLean
http://www.unix.org/single_unix_speci...
:
: 167450 (view as bug list)
Depends On: 102341
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-07-21 16:15 EDT by Jason Vas Dias
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHEA-2005-244
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 09:50:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Vas Dias 2005-07-21 16:15:22 EDT
+++ This bug was initially created as a clone of Bug #102341 +++

Description of problem:

The SUSv3 (IEEE Std 1003.1-2003) requires that

"-r Remove the jobs with the specified at_job_id operands that were previously
scheduled by the at utility."
is supported.

Since the LSB claims that -d and -r are equivalent, adding -r support should be
easy: Treat it like -d and add it to the help and manpage.



How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 4 Jason Vas Dias 2005-09-02 12:19:57 EDT
This is now fixed in CVS - 'at -r' will be documented in the man-page in the
next version.
Comment 7 Red Hat Bugzilla 2005-10-05 09:50:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-244.html
Comment 8 Marcela Mašláňová 2006-08-23 04:25:39 EDT
*** Bug 167450 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.