Bug 163912 - Tutorrial use yum-arch rather than createrepo
Tutorrial use yum-arch rather than createrepo
Status: CLOSED RAWHIDE
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul W. Frields
Karsten Wade
:
Depends On:
Blocks: 130125
  Show dependency treegraph
 
Reported: 2005-07-21 17:41 EDT by Stuart Ellis
Modified: 2009-07-07 00:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-27 10:32:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to update mirror-tutorial for createrepo (3.37 KB, text/plain)
2005-07-21 17:41 EDT, Stuart Ellis
no flags Details

  None (edit)
Description Stuart Ellis 2005-07-21 17:41:12 EDT
Description of problem:

The mirror-tutorial discusses creating yum repositories with yum-arch (for yum
v.1 ), rather than createrepo (which produces headers for yum v.2).

Note that createrepo doesn't have -l or -s flags, and accepts symlinks as
targets,  so the attached patch removes references to these flags.
Comment 1 Stuart Ellis 2005-07-21 17:41:13 EDT
Created attachment 117036 [details]
patch to update mirror-tutorial for createrepo
Comment 2 Paul W. Frields 2005-07-22 07:47:07 EDT
Thanks Stuart, especially for using our new bug components!  The patch is in
CVS. I notice that there are other parts of the tutorial that are now outdated,
given the time it's languished.  I will revisit this tutorial after I finish
edits on the yum-software-management tutorial.
Comment 3 Paul W. Frields 2005-07-22 08:33:06 EDT
I went back to the original bug list, and it appears there is a bit of weirdness
here.  This document continued to evolve (to at least version 0.28) in the
absence of the One True CVS.  After CVS opened, for whatever reason, the
mirror-tutorial I committed was not as new as the newest version available in
the original "new doc" bug (#130125).  Since the doc has been dormant since that
period, the CVS copy and the newest available XML have grown out of sync.  The
latest version available appears to have createrepo information, meaning reports
of my sloth have been greatly exaggerated. ;-D

I am reopening this bug to remind both Stuart and myself to check over the
newest copy (now in CVS) to see that it matches current technical requirements.
 I would not expect this to happen again; it is likely a consequence of our
project's initial reliance on external repositories (like my own Subversion
server), which are no longer necessary.
Comment 4 Paul W. Frields 2005-11-27 10:32:53 EST
Should be addressed in CVS at this point.
Comment 5 eric@christensenplace.us 2009-07-07 00:09:08 EDT
Ticket moved to allow products to be removed from BZ.

Note You need to log in before you can comment on or make changes to this bug.