This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 130125 - New tutorial: mirror-tutorial
New tutorial: mirror-tutorial
Status: CLOSED NEXTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul W. Frields
Karsten Wade
http://docs.frields.org
: FutureFeature
Depends On: 163912 169581 169584
Blocks: fedora-docs-ready
  Show dependency treegraph
 
Reported: 2004-08-17 07:41 EDT by Paul W. Frields
Modified: 2009-07-07 00:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-27 12:24:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Tarball ready for editorial process (18.20 KB, application/octet-stream)
2004-08-31 15:37 EDT, Paul W. Frields
no flags Details
New version, mirror-tutorial-0.21 (18.23 KB, application/octet-stream)
2004-09-02 09:19 EDT, Paul W. Frields
no flags Details
New version, mirror-tutorial-0.22 (17.11 KB, application/octet-stream)
2004-09-06 22:07 EDT, Paul W. Frields
no flags Details
New version, mirror-tutorial-0.23 (17.11 KB, application/octet-stream)
2004-09-08 15:49 EDT, Paul W. Frields
no flags Details
New version, mirror-tutorial-0.24 (17.51 KB, application/octet-stream)
2004-09-09 13:11 EDT, Paul W. Frields
no flags Details
mirror-tutorial.xml 0.24 + changes (60.85 KB, text/plain)
2004-09-09 17:31 EDT, Karsten Wade
no flags Details
New version, mirror-tutorial-0.25 (60.27 KB, text/plain)
2004-10-13 08:31 EDT, Paul W. Frields
no flags Details
Corrected version, mirror-tutorial-0.25 (60.27 KB, text/plain)
2004-10-13 15:48 EDT, Paul W. Frields
no flags Details
New version, mirror-tutorial-0.26 (18.16 KB, application/octet-stream)
2004-12-01 08:01 EST, Paul W. Frields
no flags Details
New version, mirror-tutorial-0.27 (18.30 KB, application/x-tar)
2004-12-01 08:31 EST, Paul W. Frields
no flags Details
New version, mirror-tutorial-0.28 (36.71 KB, application/octet-stream)
2005-01-30 16:24 EST, Paul W. Frields
no flags Details

  None (edit)
Description Paul W. Frields 2004-08-17 07:41:02 EDT
Description of problem:
Fedora Core users may want to support a small office (or even a home
office with several systems), classroom, or development shop with
installation, up2date, and other repository services.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
N/A

Steps to Reproduce:
N/A
  
Actual results:
N/A

Expected results:
N/A

Additional info:

The mirror-tutorial will cover locating a mirror; deciding what to
download; downloading using FTP, HTTP, and rsync; setting up servers
and clients to use up2date with a yum back end; proper configuration
of RPM macros and system-config-packages for seamless user experience
when installing or upgrading; and configuration of the server to pull
regular updates from its upstream sources.
Comment 1 Paul W. Frields 2004-08-31 15:37:49 EDT
Created attachment 103314 [details]
Tarball ready for editorial process

This is the up-to-date tarball, hopefully ready for editorial at this point.
The nightly HTML build (0400 US/Eastern time) is available at
<http://docs.frields.org>.
Comment 2 Paul W. Frields 2004-09-02 09:19:26 EDT
Created attachment 103389 [details]
New version, mirror-tutorial-0.21

This version makes a couple minor correction and brings some markup in line
with recent fedora-docs-list discussion (hopefully).
Comment 3 Paul W. Frields 2004-09-06 22:07:18 EDT
Created attachment 103519 [details]
New version, mirror-tutorial-0.22

Some additional cleanup. I think this is ready for editorial. *fingers
crossing*
Comment 4 Tammy Fox 2004-09-07 14:51:22 EDT
Karsten, want to edit this one?
Comment 5 Paul W. Frields 2004-09-08 15:49:21 EDT
Created attachment 103603 [details]
New version, mirror-tutorial-0.23

A few style edits, more voice slippage (sorry, Karsten). Apologies for the
repeated attachments, since I'm not sure exactly when someone will get around
to editing this. If you have doubts, see http://svn.frields.org to pull down a
tarball.
Comment 6 Karsten Wade 2004-09-08 16:08:22 EDT
Okay, I'll take it from here ... I've started reading it already, but
hadn't made any edits yet.  I'll start editing this afternoon/evening
(PDT), bug me by Thursday afternoon (PDT) if you haven't heard any
status, please. :)
Comment 7 Karsten Wade 2004-09-09 03:48:03 EDT
Mark Johnson recently created a good format for the introduction
<section>:

http://people.redhat.com/mjohnson/docs/fedora/docbook-emacs-quickstart/index.html#about

What do you think about adopting that template for your introductions?
 It goes like this:

1. Introduction
1.1 Purpose
1.2 Audience
1.3 About <Technology>
...
1.x Additional Resources
1.x+1 Acknowledgements

Each sub <section> only needs a paragraph or a few sentences.

Thoughts?  I'd like to get a proper introduction template for all
other tutorials to use, if we can.
Comment 8 Paul W. Frields 2004-09-09 09:24:51 EDT
Absolutely. Let me take care of that part, hopefully today if
possible. I may have time at lunch break (in RHS 333 class today) to
take care of this, and put version 0.24 up for you.
Comment 9 Paul W. Frields 2004-09-09 13:11:50 EDT
Created attachment 103643 [details]
New version, mirror-tutorial-0.24

This version includes a new introduction. I only covered an "About
<technology>" section for the concept of mirrors. I felt that the idea of
up2date, RHN, and yum were somewhat peripheral to the real mission of the
tutorial, which was actual provision of a mirror. The tutorial covers these
technologies from the perspective of how to use the mirror once it's set up.
Let me know if you disagree with my rationale.
Comment 10 Karsten Wade 2004-09-09 17:31:49 EDT
Created attachment 103655 [details]
mirror-tutorial.xml 0.24 + changes

Whoops ... we'll have to have some clear protocols about doing handoff and
document locking so we don't step on each other's toes.  I had a bunch of
little changes to the 0.23 version, so I manually merged in your additions in
0.24.  I don't think I missed anything, and I put a <!-- note --> where two
paragraphs had been removed to ask if you meant that.  IIRC, they were useful
background paragraphs.

Couple of notes on my changes so far ... <emphasis> should only be used where
you are giving something special emphasis, but not enough to make an admonition
(Note, Tip, etc.).  Similar with <quote>, that you only want to use it when
quoting someone or something.  I tried to find meaningful tags to use.	One
that troubles me is the URL that is not a <ulink> such as host.example.com.  It
might be best to untag it ... I looked through Red Hat docs and found several
usages, so there isn't really a best one.  Similar is <filename> for a package;
in this case, <package> has been accepted for the next version of DB, so we can
change that later ...

If you do a 'diff -u oldfile newfile' the changes should be fairly clear. 
There was one section where I converted an <itemizedlist> to <variablelist> so
the changes are one big block, but the rest should be clear.

Just to avoid confusion, hold off on further changes until I get done with the
edit (today).
Comment 11 Paul W. Frields 2004-09-09 20:29:21 EDT
Right about the document locking. Sorry that created a problem. I
thought I moved a couple paragraphs into the introduction where they
made more sense. I guess my use of <quote> was misguided in what I
suspect is a common error for people who haven't been DocBooking for
very long... using it to create curly quotes instead of ugly straight
ones. :-)

I didn't realize I <ulink>'d an example URL. Thinking back, I remember
having a thought that there should be a tag for a host name used as
content instead of in a real hyperlink. I probably tagged it thinking
I'd remember to fix it. Always a bad move! I'll look forward to seeing
your work.

BTW, hope it's acceptable to thread this discussion inside Bugzilla in
this fashion. It does mean, at least, that the issues won't be lost to
the ages inside my Evo folders.
Comment 12 Paul W. Frields 2004-09-17 13:27:16 EDT
Karsten, were you able to finish those edits? In answer to your <!--
note --> about those two paragraphs, they were moved to the
Introduction section where they made more sense, in the "About
Mirrors" section. It seems to me that is the place for very
rudimentary definitions of the technology that will be covered in the
body of the tutorial. I used some material by Mark Johnson as a guide.
Comment 13 Paul W. Frields 2004-10-13 08:31:26 EDT
Created attachment 105139 [details]
New version, mirror-tutorial-0.25

This final version incorporates all changes by KWade. I would consider this
ready for publication once it passes final muster by Tammy. I am going to
unblock the progress tracker and block the publication tracker; sorry this has
taken me so long.
Comment 14 Paul W. Frields 2004-10-13 15:48:31 EDT
Created attachment 105161 [details]
Corrected version, mirror-tutorial-0.25

*sigh* I forgot to edit the version entity in the last attachment, sorry!
Comment 15 Paul W. Frields 2004-11-10 11:41:32 EST
Tammy, any word on this tutorial? I have a newer version with some
very slight revisions to address FC3 and createrepo, but I am not
attaching them yet to avoid any confusion.
Comment 16 Paul W. Frields 2004-11-26 11:16:35 EST
Tickle, tickle, tickle!
Comment 17 Tammy Fox 2004-11-30 20:57:52 EST
Hi Paul. Sorry for the delay. We were working 100% on the magazine and
then I got strep throat during Thanksgiving. If you attach your newer
version I'll be sure to get it posted this week. Promise. ;-)
Comment 18 Paul W. Frields 2004-12-01 08:01:33 EST
Created attachment 107712 [details]
New version, mirror-tutorial-0.26

I hope you're feeling better now. This is a freshly minted tarball of the
current version. You can see changes at:

http://www2.frields.org:8080/viewcvs/mirror-tutorial/mirror-tutorial-en.xml?rev=89&r1=79&r2=89
Comment 19 Paul W. Frields 2004-12-01 08:31:50 EST
Created attachment 107713 [details]
New version, mirror-tutorial-0.27

Of course I found some additional errors. Corrected here in version 0.27.
Hopefully no one downloaded 0.26 in the last 30 minutes. :-)
Comment 20 Paul W. Frields 2005-01-30 15:05:34 EST
Err, tickle, tickle again!
Comment 21 Paul W. Frields 2005-01-30 16:24:28 EST
Created attachment 110418 [details]
New version, mirror-tutorial-0.28

A couple additional very minor typos. Ready and awaiting final trip through
editorial...
Comment 22 Paul W. Frields 2005-11-27 09:30:56 EST
This has been in beta for some time.  Is this ready for publishing?  Let's clear
out this cobwebby bug...
Comment 23 Karsten Wade 2005-11-27 11:34:40 EST
Publish that puppy.

I think we need to look for cruft in our processes and clear that out, too.
Shouldn't be letting good tutorials hang around.
Comment 24 Paul W. Frields 2005-11-27 12:24:20 EST
All right, that's done and tagged.  Can you do me a favor and update the web
module's include/navigation.inc file?  I don't have access to that one but it
just needs a link inserted in the array.
Comment 25 eric@christensenplace.us 2009-07-07 00:08:28 EDT
Ticket moved to allow products to be removed from BZ.

Note You need to log in before you can comment on or make changes to this bug.