Bug 163944 - iiimf eats European dead keys
iiimf eats European dead keys
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iiimf (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On: 130851
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2005-07-22 04:53 EDT by Akira TAGOH
Modified: 2007-11-30 17:11 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 03:30:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2005-07-22 04:53:44 EDT
+++ This bug was initially created as a clone of Bug #130851 +++

Description of problem:
After trying adding "XIM=htt" to ~/.i18n to get
gnome-im-switcher-applet to work, as said in Bug #113922,
the im-switcher runs fine but now dead keys on a swedish
keyboard layout doesn't work anymore.

Version-Release number of selected component (if applicable):
iiimf-gtk-11.4-46.1.svn1587
xorg-x11-6.7.0-5

How reproducible:
Always

Steps to Reproduce:
1. Add "XIM=htt" to ~/.i18n or global i18n-file
2. Log in and out from gnome.
3. Add gnome-im-switcher-applet to panel and play with that.
4. setxkbmap se
  
Actual results:
Dead keys don't work. ¨, ^ and ~ act as if they are dead but
nothing is produced. ~ + space outputs ' ', ¨ + a outputs 'a'.

Expected results:
Dead keys should work. ~ + space output '~', ¨ + a output 'ä'.

Additional info:
I have input all these characters with 'setxkblayout se nodeadkeys'
since I can't input them with the dead keys anymore.

¨, ^ and ~ are on the key right of ] on a swedish keyboard.
Comment 1 Akira TAGOH 2005-07-22 05:34:14 EDT
Fixed in 12.2-9 for devel. the dead key should work even without UNIT now
(except with non-GTK apps. look at Bug#140320). hopefully the updated packages
for FC3 and FC4 will be available soon.

Note You need to log in before you can comment on or make changes to this bug.