Bug 164016 - kernel headers missing
Summary: kernel headers missing
Status: CLOSED DUPLICATE of bug 163406
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-22 21:32 UTC by Ron Eastman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-22 22:08:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ron Eastman 2005-07-22 21:32:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
The kernel header files are missing. Instead, it installs a link:
ls -l /lib/modules/2.6.12-1.1372_FC3/build gives
"/lib/modules/2.6.12-1.1372_FC3/build -> ../../../usr/src/kernels/2.6.12-1.1372_FC3-i686", which doesn't exist.

Without the headers, one cannot compile kernel modules. For instance, I'm unable to build the vpn module which I use every day.



Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
1. Just install it.
2.
3.
  

Additional info:

Comment 1 Warren Togami 2005-07-22 22:08:32 UTC
"yum install kernel-devel" in order to workaround this problem.


*** This bug has been marked as a duplicate of 163406 ***


Note You need to log in before you can comment on or make changes to this bug.