Bug 16404 - RPM of postfix does not install correctly
Summary: RPM of postfix does not install correctly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Keywords:
: 16405 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-16 22:20 UTC by Need Real Name
Modified: 2017-09-20 17:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 22:22:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-16 22:20:57 UTC
Apologies for filing this under "sendmail" but Bugzilla for pinstripe does
not have a "postfix" component.  Postfix is an MTA on the Powertools CD.

The chrooted directories are not included in the postfix RPM off of the
pinstripe Powertools CD.  From the RPM install:

<snip>
[pjl@maynard RPMS]$ sudo rpm -Uvh postfix-20000531-5.i386.rpm
postfix                     ##################################################
install: installing multiple files, but last argument
(/var/spool/postfix/etc) is not a directory
Try `install --help' for more information.
ln: create symbolic link `/var/spool/postfix/usr/lib/zoneinfo' to
`/etc/localtime': No such file or directory
<snip>

A listing of the RPM reveals that the following directories are not included:

/var/spool/postfix/etc
/var/spool/postfix/lib
/var/spool/postfix/maildrop
/var/spool/postfix/usr/lib/zoneinfo

Add the following to %files in the spec file:

%dir %attr(-, root, root) %verify(not md5 size mtime) %{queue_directory}/etc
%dir %attr(-, root, root) %verify(not md5 size mtime) %{queue_directory}/lib
%dir %attr(-, root, root) %verify(not md5 size mtime)
%{queue_directory}/usr/lib/zoneinfo

and all will be happy...

Comment 1 Need Real Name 2000-08-16 22:22:56 UTC
*** Bug 16405 has been marked as a duplicate of this bug. ***

Comment 2 Ngo Than 2000-08-17 07:53:16 UTC
It's fixed in current rawhide. Thanks

Comment 3 openshift-github-bot 2017-09-20 17:29:56 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/f3a6d59334d611c5bc2a17b45574ad82b1dbb9b5
Merge pull request #16411 from soltysh/issue16404

Automatic merge from submit-queue

UPSTREAM: <carry>: increase timeout in TestCancelAndReadd even more

Fixes https://github.com/openshift/origin/issues/16404.

Apparently https://github.com/openshift/origin/pull/16077 didn't fix the problem. https://github.com/openshift/origin/issues/16404 is showing that we're hitting this more and more.

@mfojtik @kargakis @enj ptal


Note You need to log in before you can comment on or make changes to this bug.