Bug 1641831 - Pod Drilldown from application console behaviour changed [NEEDINFO]
Summary: Pod Drilldown from application console behaviour changed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
: 4.1.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1650400 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-22 22:43 UTC by Mike Hepburn
Modified: 2019-06-04 10:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:48 UTC
Target Upstream Version:
ktadimar: needinfo? (spadgett)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:56 UTC

Description Mike Hepburn 2018-10-22 22:43:31 UTC
Description of problem:

With 3.11 - you can no longer drilldown to your running pods by selecting 

Application WebConsole -> Overview -> (your app) Pods (circle with number component) -> select number to drilldown -> BROKEN, does not drilldown!

you have to now select Application -> Pods which shows all pods in namespace rather than a filtered list for your application

Version-Release number of selected component (if applicable):

3.11

How reproducible:

Always

Steps to Reproduce:
1. Login to web console
2. Drilldown by selecting your applications Pods (number)
3. You cannot drilldown anymore

Actual results:

Cannot drilldown

Expected results:

As per all previous OCP releases - shows you a filtered list of your pods based on the app pod number you clicked on

Additional info:

Comment 1 Samuel Padgett 2018-10-23 13:39:22 UTC
This is an intentional change. It takes you to the replication controller page now, which has a table of pods filtered for the workload. You should still see a filtered list of pods.

Can you check if this is the behavior you're seeing?

Comment 2 Mike Hepburn 2018-10-23 21:11:44 UTC
(In reply to Samuel Padgett from comment #1)
> This is an intentional change. It takes you to the replication controller
> page now, which has a table of pods filtered for the workload. You should
> still see a filtered list of pods.
> 
> Can you check if this is the behavior you're seeing?

hi samuel, ok, i see what you mean - yes, thats the behaviour - go to Deployments  -> application

this sounds dumb, but i thought it had disappeared ! when in reality the user experience is not great because you *always* have to drilldown to the pod table listing (the Template details come first) which is annoying when all you want is to get to the console of your app ;)

minor inconvenience i know, but perhaps the Pod table could be slimmed down (its full page width), there is a LOT of whitespace on right of page - and the page scroll eliminated.

thanks for taking time to check. this is vanilla 3.11

Version
OpenShift Master: v3.11.16
Kubernetes Master: v1.11.0+d4cacc0
OpenShift Web Console: v3.11.16

Comment 3 Samuel Padgett 2018-10-24 12:23:25 UTC
Thanks, Mike. Makes sense.

The 4.0 console is entirely new. Right now, clicking on the pods link from the overview in 4.0 takes you directly to the pods table. It's on a separate tab. I think the behavior in 4.0 is in line with your expectation.

Comment 4 Yadan Pei 2018-10-25 09:18:52 UTC
In 4.0 console

1. Login to console
2. Home -> Overview -> selecting/clicking the app pods number (for example, 2 of 2)
it takes you to resources' pods tab, that's all pods of your app where you can select pods and goes to its Terminal

Does this satisfy you? If yes, I will verify the bug

Comment 5 Mike Hepburn 2018-10-25 09:31:32 UTC
(In reply to Yadan Pei from comment #4)
> In 4.0 console
> 
> 1. Login to console
> 2. Home -> Overview -> selecting/clicking the app pods number (for example,
> 2 of 2)
> it takes you to resources' pods tab, that's all pods of your app where you
> can select pods and goes to its Terminal
> 
> Does this satisfy you? If yes, I will verify the bug

Sounds good to me .. i will try out in 4.0 as well when i get a chance. Thanks a lot!

Comment 6 Yadan Pei 2018-10-26 02:06:55 UTC
Move to VERIFIED per comment 5, feel free to reopen if that's not what you actually want

Comment 7 Samuel Padgett 2018-11-16 13:49:46 UTC
*** Bug 1650400 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2019-06-04 10:40:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.