Bug 1641989 - No pre-edit shown when using ibus-libpinyin
Summary: No pre-edit shown when using ibus-libpinyin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-libpinyin
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-23 10:17 UTC by Jonas Ådahl
Modified: 2018-11-10 03:29 UTC (History)
4 users (show)

Fixed In Version: ibus-libpinyin-1.10.92-1.fc29 ibus-libpinyin-1.10.92-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-03 00:01:35 UTC


Attachments (Terms of Use)
video of missing pre-edit (45.96 KB, application/octet-stream)
2018-10-25 10:12 UTC, Jonas Ådahl
no flags Details
Video of working pre-edit (recorded on F28) (162.89 KB, application/octet-stream)
2018-10-25 10:19 UTC, Jonas Ådahl
no flags Details

Description Jonas Ådahl 2018-10-23 10:17:52 UTC
Description of problem:

When typing chinese using ibus-libpinyin, no preedit text is shown, but I can still commit text.

The same issue exist everywhere, gtk2, gtk3, xterm, Firefox, LibreOffice, ...

I have tried other input methods (e.g. hangul) and preedit works for those.

Version-Release number of selected component (if applicable):

ibus-1.5.19-4.fc29.x86_64
ibus-libpinyin-1.10.91-1.fc29.x86_64
mutter-3.30.1-4.fc29.x86_64 (also tried with 3.30.1-2)
gnome-shell-3.30.1-2.fc29.x86_64 (also tried with 3.30.1-1)

How reproducible:


Steps to Reproduce:
1. Select libpinyin
2. Enter some pinyin


Actual results:
No preedit text is shown, just the popup with character selection.

Expected results:
Preedit text should be shown.

Additional info:
I have both https://bugzilla.redhat.com/show_bug.cgi?id=1632981 and https://bugzilla.redhat.com/show_bug.cgi?id=1637418 fixes applied, but also verified that the issue was reproduceable without those fixes.

Comment 1 fujiwara 2018-10-23 11:53:45 UTC
I cannot reproduce your problem.

Comment 2 Jonas Ådahl 2018-10-23 12:05:50 UTC
Any way I can debug it? I tried both Xorg and Wayland session and it works the same.

Comment 3 Peng Wu 2018-10-25 09:56:36 UTC
I can't reproduce this bug, either.

Maybe some screenshot will help on it?

Comment 4 Jens Petersen 2018-10-25 10:09:23 UTC
I tried testing this in Fedora-Workstation-Live-x86_64-29-20181024.n.0.iso.

I can input hello in Chinese in gedit for example:

1. activate "Chinese (Intelligent Pinyin)"
2. input 'nihao' with keyboard
3. (pre-edit now shows "你好", which is also the first listed candidate)
4. commit with space
5. (buffer now show "你好")

Comment 5 Jonas Ådahl 2018-10-25 10:12:37 UTC
Created attachment 1497399 [details]
video of missing pre-edit

Here's a video of entering text in gedit. On F28 I'd get the pre-edit string with an underline inside gedit text view, not just in the popup.

Comment 6 Jonas Ådahl 2018-10-25 10:19:09 UTC
Created attachment 1497401 [details]
Video of working pre-edit (recorded on F28)

Here's a video I just recorded on F28 where it works as expected.

Comment 7 Peng Wu 2018-10-25 11:07:24 UTC
After turn on Traditional Chinese option, I can reproduce this bug on Fedora 28/29

Comment 8 Jonas Ådahl 2018-10-25 11:23:49 UTC
Ah, right, yes, I use libpinyin with traditional characters, indeed. Should have included that in the initial description, sorry!

Comment 10 Jonas Ådahl 2018-10-26 11:55:47 UTC
Thanks! Will it be backported to F29?

Comment 11 Peng Wu 2018-10-29 05:41:34 UTC
Sure, will back port the patch.

Comment 12 Fedora Update System 2018-10-31 08:07:02 UTC
ibus-libpinyin-1.10.92-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-41a56b4f02

Comment 13 Fedora Update System 2018-10-31 08:07:09 UTC
ibus-libpinyin-1.10.92-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-01fd5f9add

Comment 14 Fedora Update System 2018-10-31 17:31:49 UTC
ibus-libpinyin-1.10.92-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-01fd5f9add

Comment 15 Fedora Update System 2018-10-31 18:52:17 UTC
ibus-libpinyin-1.10.92-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-41a56b4f02

Comment 16 Fedora Update System 2018-11-03 00:01:35 UTC
ibus-libpinyin-1.10.92-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2018-11-10 03:29:14 UTC
ibus-libpinyin-1.10.92-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.