Bug 164249 - kernel-2.6.12-1.1372_FC3 has bad symlink for /lib/modules/2.6.12-1.1372_FC3/build
kernel-2.6.12-1.1372_FC3 has bad symlink for /lib/modules/2.6.12-1.1372_FC3/b...
Status: CLOSED DUPLICATE of bug 163406
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-07-26 04:49 EDT by James Brusey
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-07-28 02:32:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Brusey 2005-07-26 04:49:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
After booting kernel-2.6.12-1.1372_FC3 for the first time, I was in the process of rebuilding the NVIDIA driver and found that it was failing saying that I didn't have the source. After a bit of checking I realised that the "kernel-source-path" defaults to /lib/modules/2.6.12-1.1372_FC3/build. I then found that this was a broken symlink:

# ls -l /lib/modules/2.6.12-1.1372_FC3/build
lrwxrwxrwx  1 root root 47 Jul 26 09:21 /lib/modules/2.6.12-1.1372_FC3/build -> ../../../usr/src/kernels/2.6.12-1.1372_FC3-i686

I guess I *could* provide source in this directory, but the NVIDIA driver compile worked for me ok under the previous package (kernel-2.6.11-1.35_FC3).

I have noticed a number of SMP problems relating to this kernel, but I am using the UP version.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install kernel-2.6.12-1.1372_FC3
2. ls -l /lib/modules/2.6.12-1.1372_FC3/build


Actual Results:  symlink was broken and pointing to ../../../usr/src/kernels...

Expected Results:  should be directory similar to previous kernel builds

Additional info:
Comment 1 Dave Jones 2005-07-28 02:32:21 EDT

*** This bug has been marked as a duplicate of 163406 ***

Note You need to log in before you can comment on or make changes to this bug.