Bug 164270 - libcdio-0.74-2.fc4 causes dependency conflict with updated libcddb
libcdio-0.74-2.fc4 causes dependency conflict with updated libcddb
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libcdio (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
: 164319 164349 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-26 10:10 EDT by Sven Wahl
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version: libcdio-0.75-3.fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 04:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sven Wahl 2005-07-26 10:10:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
libcdio-0.74-2.fc4 causes a dependency conflict when attempting to update libcddb to the latest version. For full error message, see below.


Version-Release number of selected component (if applicable):
0.74-2.fc4

How reproducible:
Always

Steps to Reproduce:
Attempting to update libcddb to latest version 1.1.0-1.fc4

Actual Results:  $ /usr/bin/sudo /usr/bin/yum update

Yum Version: 2.3.2
COMMAND: yum update
Installroot: /
Setting up Update Process
Setting up repositories
Baseurl(s) for repo: ['http://ftp.heanet.ie/pub/fedora/linux/core/4/i386/os/']
core-stable               100% |=========================| 1.1 kB    00:00
Baseurl(s) for repo: ['http://fedoraproject.org/extras/4/i386/']
extras-fedoraproject-stab 100% |=========================| 1.1 kB    00:00
Baseurl(s) for repo: ['http://ftp.heanet.ie/pub/fedora/linux/core/updates/4/i386/']
core-stable-updates       100% |=========================|  951 B    00:00
Baseurl(s) for repo: ['http://rpm.livna.org/fedora/4/i386/RPMS.lvn/']
extras-livna              100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Setting up Package Sacks
Excluding Incompatible Archs
Finished
Reading Local RPMDB
Building updates object
Resolving Dependencies
1122384922.98
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libcddb to pack into transaction set.
libcddb-1.1.0-1.fc4.i386. 100% |=========================| 3.8 kB    00:00
---> Package libcddb.i386 0:1.1.0-1.fc4 set to be updated
--> Running transaction check
# of Deps = 1
--> Processing Dependency: libcddb.so.0 for package: libcdio
Matched libcddb - 1.0.2-2.i386 to require for libcddb.so.0
--> Finished Dependency Resolution
Error: Missing Dependency: libcddb.so.0 is needed by package libcdio

$

Additional info:
Comment 1 Adrian Reber 2005-07-26 10:24:14 EDT
Build request for the new libcdio is already in the queue to be build and should
be available soon.
Comment 2 Michael Schwendt 2005-07-26 11:00:45 EDT
Due to the circular build dependency of libcdio and libcddb, what's the right
order with which to process the build requests?  I've moved the requests to the
top of the tobuild file, in hope that the order speeds up the builds when
feeding them to the new build system. But I'm not sure the circular dependency
is trouble-free. Thoughts?
Comment 3 Michael Schwendt 2005-07-26 11:03:16 EDT
e.g. for FE devel, the new libcdio-0.75-1.fc5 breaks the ABI with libcddb-1.0.2-2
Error: Missing Dependency: libcdio.so.5 is needed by package libcddb
Error: Missing Dependency: libcdio.so.5(CDIO_5) is needed by package libcddb

For FC4 that would mean: first update libcddb, then libcdio. But for devel?
Comment 4 Adrian Reber 2005-07-26 11:12:59 EDT
One of the packages has to be build two times. This is either libcddb or
libcdio. As libcddb has been build first in the FC-4 branch it has to be rebuild
again after libcdio has been build. The main problem is that libcdio depends on
libcdio and libcdio depends on libcddb. 
So now libcdio has to be rebuild and if there is not again an ABI break between
libcddb 1.1.0 and libcddb 1.2.0 it should be enough if libcddb is build after
libcdio.

We (Anvil and I) tried to coordinate the upgrade of both libraries but it seems
that our efforts didn't work pretty good.
Comment 5 Michael Schwendt 2005-07-26 11:25:57 EDT
Please take a look at the top of the current tobuild file and sort the
requests as needed. The build system might choke on trying to install what's in
the FE4 repo currently.
Comment 6 Adrian Reber 2005-07-26 11:33:59 EDT
I changed the order in the tobuild file.
You are probably right that the buildsystem will choke when trying to install
the build dependencies. It would be necessary to request a build of libcdio
without the dependency on libcddb and if this succeeds another build with the
dependency enabled will be required.
I will now wait what the buildsystem reports on the build request and if it
fails I will request another build as described above.
Comment 7 Michael Schwendt 2005-07-26 22:54:22 EDT
*** Bug 164319 has been marked as a duplicate of this bug. ***
Comment 8 Michael Schwendt 2005-07-27 07:52:42 EDT
*** Bug 164349 has been marked as a duplicate of this bug. ***
Comment 9 Adrian Reber 2005-07-27 08:06:22 EDT
And indeed has the buildsystem choked on the build of libcdio-0.75-2.fc4 as it
can be seen in: http://buildsys.fedoraproject.org/logs//4/3-libcdio-0.75-2.fc4/

I have now a buildrequest for libcdio-0.75-3.fc4 in the queue without requiring
libcddb.
Comment 10 Michael Schwendt 2005-07-27 20:17:57 EDT
Interestingly, libcddb-1.2.0-1.fc4 built successfully, but only because via
libcdio-devel it pulled in the older libcddb-1.0.2-2 instead of the current
libcddb-1.1.0-1.fc4.
Comment 11 Adrian Reber 2005-07-28 02:48:14 EDT
Okay, now libcdio has been rebuild, but libcddb has been build against the old
version of libcdio. libcddb has now to be rebuilt. I will try to reach the
maintainer.
Comment 12 Adrian Reber 2005-07-28 04:26:17 EDT
This is now fixed. Packages from external repositories using these libraries
(libcdio, libcddb) have to be now also rebuilt.
Comment 13 Sven Wahl 2005-07-28 05:16:42 EDT
(In reply to comment #12)
> This is now fixed.

Great job, Adrian! Thanks a lot for your efforts!


> Packages from external repositories using these libraries
> (libcdio, libcddb) have to be now also rebuilt.

On my installation that is 

vcdimager-0.7.21-0.lvn.1.4 and
xine-lib-1.0.1-0.lvn.10.4

from the rpm.livna.org repository. Anyone of you who has an account at
http://bugzilla.livna.org/ and would care about requesting a rebuild?
Comment 14 Sven Wahl 2005-07-29 03:12:07 EDT
(In reply to comment #13)
> On my installation that is 
> 
> vcdimager-0.7.21-0.lvn.1.4 and
> xine-lib-1.0.1-0.lvn.10.4
> 
> from the rpm.livna.org repository. Anyone of you who has an account at
> http://bugzilla.livna.org/ and would care about requesting a rebuild?

These packages have now been rebuilt as

vcdimager-0.7.21-0.lvn.2.4 and
xine-lib-1.0.1-0.lvn.11.4

making the update of libcdio and libcddb flawless.

Note You need to log in before you can comment on or make changes to this bug.