Bug 1642807 - remove 'tier' translator from build and code
Summary: remove 'tier' translator from build and code
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1635688
TreeView+ depends on / blocked
 
Reported: 2018-10-25 06:29 UTC by Amar Tumballi
Modified: 2019-03-25 16:31 UTC (History)
2 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:31:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 21331 None Open tiering: remove the translator from build and glusterd 2018-11-02 02:40:16 UTC

Description Amar Tumballi 2018-10-25 06:29:32 UTC
Tasks involved:

* Remove translator from the build & Tests (get the bare minimum code for this).
* Add documentation on migration steps.
* Remove the code from repo (dht-rebalance, glusterd etc).

Comment 1 Worker Ant 2018-10-25 08:19:30 UTC
REVIEW: https://review.gluster.org/21331 (tiering: remove the translator from build and glusterd) posted (#7) for review on master by Amar Tumballi

Comment 2 hari gowtham 2018-10-31 06:37:07 UTC
Bug to remove the deep intergrated tier code with dht and glusterd https://bugzilla.redhat.com/show_bug.cgi?id=1644527

Comment 3 Worker Ant 2018-11-02 02:40:14 UTC
REVIEW: https://review.gluster.org/21331 (tiering: remove the translator from build and glusterd) posted (#8) for review on master by Atin Mukherjee

Comment 4 Shyamsundar 2019-03-25 16:31:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.