Bug 1635688 - Keep only the valid (maintained/supported) components in the build
Summary: Keep only the valid (maintained/supported) components in the build
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1364707 1642802 1642804 1642807 1642810
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-03 13:35 UTC by Amar Tumballi
Modified: 2020-03-13 05:50 UTC (History)
4 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-13 05:50:25 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 20702 0 None Open bd: remove from the build 2018-11-08 07:37:30 UTC
Gluster.org Gerrit 21329 0 None Abandoned decompounder: remove the translator from build and glusterd 2019-02-06 19:32:20 UTC
Gluster.org Gerrit 21537 0 None Open xlators/experimental: remove from the build 2018-11-08 02:47:02 UTC
Gluster.org Gerrit 21807 0 None Open encryption: remove crypt xlator from build 2018-12-11 11:06:54 UTC
Gluster.org Gerrit 21812 0 None Open all: remove code which is not being considered in build 2018-12-13 17:10:47 UTC
Gluster.org Gerrit 21847 0 None Open symlink-cache: remove from the build 2018-12-13 06:13:33 UTC
Gluster.org Gerrit 21877 0 None Open glusterd: manage upgrade to current master 2019-02-04 03:47:48 UTC
Gluster.org Gerrit 22381 0 None Open Multiple files: remove HAVE_BD_XLATOR related code. 2019-03-25 05:35:38 UTC
Gluster.org Gerrit 23033 0 None Open ibverbs/rdma: remove from build 2019-07-14 05:17:36 UTC
Gluster.org Gerrit 23074 0 None Abandoned rdma: remove from remaining part in code 2019-11-04 19:31:02 UTC

Description Amar Tumballi 2018-10-03 13:35:37 UTC
Description of problem:
As the project matures, we need a thorough review of supported components once in a while to keep the best quality of the project!

As described in https://lists.gluster.org/pipermail//gluster-users/2018-July/034400.html we would like to retire some now, and also keep it a habbit to review the components every 3 major releases at least.

Version-Release number of selected component (if applicable):
master


Expected results:
Periodically keep discontinuing the features which are not supported! 

Additional info:
This bug can be always open!

Comment 1 Amar Tumballi 2018-10-03 13:40:33 UTC
For better readability of the above message: https://lists.gluster.org/pipermail//gluster-users/2018-July/034408.html

Comment 2 Worker Ant 2018-10-16 17:10:15 UTC
REVIEW: https://review.gluster.org/21332 (glupy: remove from the build) posted (#2) for review on master by Amar Tumballi

Comment 3 Worker Ant 2018-10-17 11:29:54 UTC
REVIEW: https://review.gluster.org/21331 (tiering: remove the translator from build and glusterd) posted (#2) for review on master by Amar Tumballi

Comment 4 Worker Ant 2018-10-22 07:54:45 UTC
REVIEW: https://review.gluster.org/20702 (bd: remove from the build) posted (#3) for review on master by Amar Tumballi

Comment 5 Worker Ant 2018-10-23 13:55:14 UTC
REVIEW: https://review.gluster.org/21329 (decompounder: remove the translator from build and glusterd) posted (#2) for review on master by Amar Tumballi

Comment 6 Worker Ant 2018-10-25 07:13:51 UTC
REVISION POSTED: https://review.gluster.org/21433 (stripe: remove the translator from build and glusterd) posted (#9) for review on master by Amar Tumballi

Comment 7 Worker Ant 2018-10-25 08:19:27 UTC
REVISION POSTED: https://review.gluster.org/21331 (tiering: remove the translator from build and glusterd) posted (#7) for review on master by Amar Tumballi

Comment 8 Worker Ant 2018-11-02 05:36:40 UTC
REVIEW: https://review.gluster.org/21537 (xlators/experimental: remove from the build) posted (#1) for review on master by Amar Tumballi

Comment 9 Worker Ant 2018-11-08 02:47:01 UTC
REVIEW: https://review.gluster.org/21537 (xlators/experimental: remove from the build) posted (#4) for review on master by Amar Tumballi

Comment 10 Worker Ant 2018-11-08 07:37:28 UTC
REVIEW: https://review.gluster.org/20702 (bd: remove from the build) posted (#10) for review on master by Amar Tumballi

Comment 11 Worker Ant 2018-12-05 15:14:02 UTC
REVIEW: https://review.gluster.org/21807 (encryption: remove crypt xlator from build) posted (#1) for review on master by Amar Tumballi

Comment 12 Worker Ant 2018-12-06 08:25:46 UTC
REVIEW: https://review.gluster.org/21812 (all: remove dead-code) posted (#1) for review on master by Amar Tumballi

Comment 13 Worker Ant 2018-12-11 11:06:53 UTC
REVIEW: https://review.gluster.org/21807 (encryption: remove crypt xlator from build) posted (#3) for review on master by Amar Tumballi

Comment 14 Worker Ant 2018-12-11 11:09:44 UTC
REVIEW: https://review.gluster.org/21847 (symlink-cache: remove from the build) posted (#1) for review on master by Amar Tumballi

Comment 15 Worker Ant 2018-12-13 06:13:32 UTC
REVIEW: https://review.gluster.org/21847 (symlink-cache: remove from the build) posted (#2) for review on master by Amar Tumballi

Comment 16 Worker Ant 2018-12-13 17:10:46 UTC
REVIEW: https://review.gluster.org/21812 (all: remove code which is not being considered in build) posted (#4) for review on master by Amar Tumballi

Comment 17 Worker Ant 2018-12-17 12:13:41 UTC
REVIEW: https://review.gluster.org/21877 (glusterd: manage upgrade to current master) posted (#1) for review on master by Amar Tumballi

Comment 18 Worker Ant 2019-02-04 03:47:49 UTC
REVIEW: https://review.gluster.org/21877 (glusterd: manage upgrade to current master) merged (#3) on master by Atin Mukherjee

Comment 19 Worker Ant 2019-02-25 11:05:49 UTC
REVIEW: https://review.gluster.org/22259 (build: include gluster/__init__.* files for python packaging) posted (#1) for review on release-6 by Niels de Vos

Comment 20 Worker Ant 2019-02-25 11:17:48 UTC
REVISION POSTED: https://review.gluster.org/22259 (build: include gluster/__init__.* files for python packaging) posted (#2) for review on release-6 by Niels de Vos

Comment 21 Worker Ant 2019-03-20 05:40:44 UTC
REVIEW: https://review.gluster.org/22381 (Multiple files: remove HAVE_BD_XLATOR related code.) posted (#2) for review on master by Yaniv Kaul

Comment 22 Worker Ant 2019-03-25 05:35:39 UTC
REVIEW: https://review.gluster.org/22381 (Multiple files: remove HAVE_BD_XLATOR related code.) merged (#3) on master by Atin Mukherjee

Comment 23 Shyamsundar 2019-03-25 16:31:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 24 Worker Ant 2019-03-25 17:10:38 UTC
REVIEW: https://review.gluster.org/22415 ([WIP] graph.c: remove extra gettimeofday() - reuse the graph dob.) posted (#1) for review on master by Yaniv Kaul

Comment 25 Worker Ant 2019-03-26 06:22:32 UTC
REVISION POSTED: https://review.gluster.org/22415 ([WIP] graph.c: remove extra gettimeofday() - reuse the graph dob.) posted (#2) for review on master by Yaniv Kaul

Comment 26 Amar Tumballi 2019-05-18 06:30:56 UTC
The major work with this bug is complete, and is available with glusterfs-6.x release. We can use other bugs to track the minor cleanups (if any).

Comment 27 Worker Ant 2019-07-12 10:51:05 UTC
REVIEW: https://review.gluster.org/23033 (ibverbs/rdma: remove from build) posted (#1) for review on master by Amar Tumballi

Comment 28 Worker Ant 2019-07-14 05:17:37 UTC
REVIEW: https://review.gluster.org/23033 (ibverbs/rdma: remove from build) merged (#2) on master by Amar Tumballi

Comment 29 Worker Ant 2019-07-19 06:26:19 UTC
REVIEW: https://review.gluster.org/23074 (rdma: remove from remaining part in code) posted (#1) for review on master by Amar Tumballi

Comment 30 Worker Ant 2020-03-13 05:50:25 UTC
This bug is moved to https://github.com/gluster/glusterfs/issues/1097, and will be tracked there from now on. Visit GitHub issues URL for further details


Note You need to log in before you can comment on or make changes to this bug.