Bug 1642810 - remove glupy from code and build
Summary: remove glupy from code and build
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1635688 1680585
TreeView+ depends on / blocked
 
Reported: 2018-10-25 06:34 UTC by Amar Tumballi
Modified: 2019-03-25 16:31 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:31:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21332 0 None Open glupy: remove from the build 2018-11-08 02:47:29 UTC
Gluster.org Gerrit 22256 0 None Open build: include gluster/__init__.* files for python packaging 2019-02-25 05:18:34 UTC

Description Amar Tumballi 2018-10-25 06:34:11 UTC
Tasks involved:

* Remove from the build & remove the tests
* remove the code

Comment 1 Worker Ant 2018-10-25 07:28:42 UTC
REVIEW: https://review.gluster.org/21332 (glupy: remove from the build) posted (#6) for review on master by Amar Tumballi

Comment 2 Worker Ant 2018-11-08 02:47:28 UTC
REVIEW: https://review.gluster.org/21332 (glupy: remove from the build) posted (#8) for review on master by Amar Tumballi

Comment 3 Worker Ant 2019-02-22 14:20:56 UTC
REVIEW: https://review.gluster.org/22256 (build: include gluster/__init__.* files for python packaging) posted (#1) for review on master by Niels de Vos

Comment 4 Worker Ant 2019-02-25 05:18:35 UTC
REVIEW: https://review.gluster.org/22256 (build: include gluster/__init__.* files for python packaging) merged (#3) on master by Niels de Vos

Comment 5 Shyamsundar 2019-03-25 16:31:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.