Bug 1642923 - Deployment playbook fails at task "Enable RHEL repositories" with error "'openshift_version' is undefined"
Summary: Deployment playbook fails at task "Enable RHEL repositories" with error "'ope...
Keywords:
Status: CLOSED DUPLICATE of bug 1642929
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.11.z
Assignee: Tzu-Mainn Chen
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-25 10:21 UTC by Mohammed Salih
Modified: 2018-12-03 14:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-03 14:52:24 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mohammed Salih 2018-10-25 10:21:39 UTC
Description of problem:
Deployment playbook fails at task "Enable RHEL repositories" with error "'openshift_version' is undefined". 'openshift_version' variable is supposed to be derived automatically during the playbook run.
here is the output from failing task. https://paste.fedoraproject.org/paste/urrC2jkdIx88viVjx5T8eA

Provisioning was done using command
ansible-playbook --user openshift -i /usr/share/ansible/openshift-ansible/playbooks/openstack/inventory.py -i inventory /usr/share/ansible/openshift-ansible/playbooks/openstack/openshift-cluster/provision.yml

Workaround or a fix would be to include "- import_playbook: ../../init/version.yml" to /usr/share/ansible/openshift-ansible/playbooks/openstack/openshift-cluster/provision.yml

Version-Release number of selected component (if applicable):
OCP version 3.11

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tzu-Mainn Chen 2018-12-03 14:52:24 UTC

*** This bug has been marked as a duplicate of bug 1642929 ***


Note You need to log in before you can comment on or make changes to this bug.