Bug 1642929 - During OpenShift Install (/usr/share/ansible/openshift-ansible/playbooks/openstack/openshift-cluster/install.yml), the playbook fails at task "Enable RHEL repositories" with error "'openshift_version' is undefined"
Summary: During OpenShift Install (/usr/share/ansible/openshift-ansible/playbooks/open...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.11.z
Assignee: Tzu-Mainn Chen
QA Contact: weiwei jiang
URL:
Whiteboard:
: 1642923 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-25 10:26 UTC by Mohammed Salih
Modified: 2019-02-20 14:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-20 14:11:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0326 None None None 2019-02-20 14:11:07 UTC

Description Mohammed Salih 2018-10-25 10:26:15 UTC
Description of problem:
During OpenShift Install (/usr/share/ansible/openshift-ansible/playbooks/openstack/openshift-cluster/install.yml), the playbook fails at task "Enable RHEL repositories" with error "'openshift_version' is undefined". 'openshift_version' variable is supposed to be derived automatically during the playbook run. 

Please note that this bug is similar to bz-1642923 , but in this case it is in install.yml. 

Tried to workaround the issue by adding "- import_playbook: ../../init/version.yml" to install.yml , but didn't work. 

On the otherhand if I use the provision_install.yml it gets past the registration.

Version-Release number of selected component (if applicable):
OCP 3.11

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tzu-Mainn Chen 2018-11-21 15:35:47 UTC
I believe this should be fixed in a more recent version of 3.11: https://github.com/openshift/openshift-ansible/pull/10504

Comment 2 Tzu-Mainn Chen 2018-12-03 14:51:49 UTC
Fixed by https://github.com/openshift/openshift-ansible/pull/10742

Comment 3 Tzu-Mainn Chen 2018-12-03 14:52:24 UTC
*** Bug 1642923 has been marked as a duplicate of this bug. ***

Comment 4 Scott Dodson 2019-01-28 14:48:47 UTC
In openshift-ansible-3.11.55-1 and later

Comment 5 weiwei jiang 2019-01-29 05:15:25 UTC
verified on

# rpm -qa|grep -i ansible
ansible-2.6.12-1.el7ae.noarch
openshift-ansible-playbooks-3.11.75-1.git.0.95e8e2a.el7.noarch
openshift-ansible-3.11.75-1.git.0.95e8e2a.el7.noarch
openshift-ansible-docs-3.11.75-1.git.0.95e8e2a.el7.noarch
openshift-ansible-roles-3.11.75-1.git.0.95e8e2a.el7.noarch

Comment 7 errata-xmlrpc 2019-02-20 14:11:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0326


Note You need to log in before you can comment on or make changes to this bug.