Bug 1643059 - Download button performs the download, but then changes back to Download
Summary: Download button performs the download, but then changes back to Download
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker https://fedoraproject...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-25 12:39 UTC by Kamil Páral
Modified: 2018-12-22 03:01 UTC (History)
7 users (show)

Fixed In Version: gnome-software-3.30.6-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-22 03:01:58 UTC
Type: Bug


Attachments (Terms of Use)
packagekit verbose log (636.55 KB, text/plain)
2018-10-25 12:41 UTC, Kamil Páral
no flags Details
rpm-qa (53.96 KB, text/plain)
2018-10-25 12:42 UTC, Kamil Páral
no flags Details
video demonstration (6.02 MB, application/octet-stream)
2018-10-25 13:05 UTC, Kamil Páral
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1640701 0 unspecified CLOSED GNOME Software "update and restart" button appears to do nothing 2021-02-22 00:41:40 UTC

Internal Links: 1640701

Description Kamil Páral 2018-10-25 12:39:06 UTC
Description of problem:
This was already mentioned here:
https://bodhi.fedoraproject.org/updates/libappstream-glib-0.7.14-2.fc29%20gnome-software-3.30.5-1.fc29#comment-852575
and in bug 1640701.

I press the Download button in gnome-software, it changes to Cancel, downloads the packages in the background, and then changes to Download again. Can't install the updates.

I managed to reproduce this when I installed F29 Workstation Live, updated dnf and gnome-software to latest versions, enabled updates-testing, executed "pkcon refresh force" to make sure packagekit noticed, and then used gnome-software the download the update.

Version-Release number of selected component (if applicable):
appstream-data-29-6.fc29.noarch
gnome-software-3.30.5-1.fc29.x86_64
libappstream-glib-0.7.14-2.fc29.x86_64
PackageKit-1.1.10-4.fc29.x86_64
PackageKit-command-not-found-1.1.10-4.fc29.x86_64
PackageKit-glib-1.1.10-4.fc29.x86_64
PackageKit-gstreamer-plugin-1.1.10-4.fc29.x86_64
PackageKit-gtk3-module-1.1.10-4.fc29.x86_64


How reproducible:
I don't know

Steps to Reproduce:
1. see description

Comment 1 Kamil Páral 2018-10-25 12:41:41 UTC
Created attachment 1497439 [details]
packagekit verbose log

This is output from packagekit --verbose. It doesn't contain the initial downloading of packages, because packagekit wasn't running in verbose mode back then. I had to stop the service and start the deamon manually in verbose mode, then click on Download again. This time it's faster (doesn't download packages), but still goes back to Download. Hopefully the log helps.

I actually click on Download twice, in the very beginning in the log, and then once more around 14:32:16.

Comment 2 Kamil Páral 2018-10-25 12:42:08 UTC
Created attachment 1497440 [details]
rpm-qa

Comment 3 Kamil Páral 2018-10-25 12:43:52 UTC
Proposing for a blocker discussion, so that it doesn't get lost. Will try to figure out if I can reproduce this reliably.

Comment 4 Kamil Páral 2018-10-25 12:47:58 UTC
After rebooting that machine, gnome-software immediately shown Restart&Update button instead of Download, and the offline update was started just fine. So whatever the bug is, it seems to be worked around by rebooting.

Comment 5 Kamil Páral 2018-10-25 13:05:24 UTC
Created attachment 1497459 [details]
video demonstration

It seems I can reproduce it consistently (from a VM snapshot I made after installing F29 Beta and updating dnf and gnome-software). See the video.

Note that after Download changes back to Download, gnome-software completely refreshes the whole page (takes a while). In the video, it happens every time (two out of two), but overall I see it do that only sometimes, and sometimes it doesn't do the full refresh. Not sure whether it's related, just mentioning.

Comment 6 Kamil Páral 2018-10-25 13:24:45 UTC
"killall gnome-software" also resolves this problem (without reboot), the next time you run gnome-software the button is labeled correctly (Restart&Update)

Comment 7 Geoffrey Marr 2018-10-25 17:31:06 UTC
Discussed during the 2018-10-25 Fedora 29 Final Go/No-Go meeting:

The decision to classify this bug as a “RejectedBlocker” was made as several testers cannot reproduce this. Since there is a workaround it will be added to CommonBugs in case users encounter it.

Comment 8 Kalev Lember 2018-12-18 02:19:36 UTC
This is hopefully fixed in gnome-software 3.30.6 + PackageKit-1.1.12-2.fc29 update, at least I'm unable to reproduce it any more here.

Comment 9 Fedora Update System 2018-12-19 03:36:29 UTC
PackageKit-1.1.12-2.fc29, gnome-software-3.30.6-1.fc29, libappstream-glib-0.7.14-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e0db56c00c

Comment 10 Fedora Update System 2018-12-22 03:01:58 UTC
PackageKit-1.1.12-2.fc29, gnome-software-3.30.6-1.fc29, libappstream-glib-0.7.14-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.